































































  
           
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Blog Post" />
  
    <meta name="oid" content="15292187" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=7834146fb06632665a4b788b2307c5fe" />
  <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=7834146fb06632665a4b788b2307c5fe" />
  <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=7834146fb06632665a4b788b2307c5fe" />
  <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=7834146fb06632665a4b788b2307c5fe" />

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Salt Lake City Weekly RSS: Whole Site" href="https://www.cityweekly.net/utah/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Salt Lake City Weekly RSS: Blog Section" href="https://www.cityweekly.net/utah/Rss.xml?oid=2125737" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Salt Lake City Weekly RSS: Buzz Blog" href="https://www.cityweekly.net/utah/Rss.xml?oid=2125738" />
      
        <link rel="alternate" type="application/rss+xml" title="Salt Lake City Weekly RSS: Buzz Blog: " href="https://www.cityweekly.net/utah/Rss.xml?category=2125738&amp;topic=oid%3A2125752" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Salt Lake City Weekly RSS: Comments on Buzz Blog" href="https://www.cityweekly.net/utah/Rss.xml?id=comments&amp;oid=2125738" />
      
        <link rel="alternate" type="application/rss+xml" title="Salt Lake City Weekly RSS: Comments on Buzz Blog: " href="https://www.cityweekly.net/utah/Rss.xml?category=2125738&amp;id=comments&amp;topic=oid%3A2125752" />
      
    
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
      
      <script>
        if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
      </script>
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=f367629b4a1ff90fa851b8c0e149a3fa"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=f367629b4a1ff90fa851b8c0e149a3fa"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  
  

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("https:\/\/www.cityweekly.net\/utah\/Profile", "https:\/\/posting.cityweekly.net\/utah\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="994967671027-8onjgidd96k7ia5node65hqvciq4ko73.apps.googleusercontent.com">
  

    
  

  
  <!-- Begin Google Web Font API Call -->
<link href='https://fonts.googleapis.com/css?family=Fjalla+One|Yanone+Kaffeesatz:700|Playfair+Display:400,700' rel='stylesheet' type='text/css'>
<!-- End Google Web Font API Call -->

<script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            (function() {
              var gads = document.createElement('script');
              gads.async = true;
              gads.type = 'text/javascript';
              var useSSL = 'https:' == document.location.protocol;
              gads.src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
              var node = document.getElementsByTagName('script')[0];
              node.parentNode.insertBefore(gads, node);
            })();
          </script>
          <script type='text/javascript'>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</script>

<!-- Initiate Chartbeat tracking Also see code at end of body  -->
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
<!-- End Chartbeat initiating code -->








<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
 fbq('init', '1832028880415856'); 
fbq('track', 'PageView');
</script>
<noscript>
 <img height="1" width="1" 
src="https://www.facebook.com/tr?id=1832028880415856&ev=PageView
&noscript=1"/>
</noscript>
<!-- End Facebook Pixel Code -->
  
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="Holiday Weekend Music Update | Buzz Blog" />
  <meta name="description" content="Virtual Fest for S&amp;amp;S Before Ritt Momney got their start as indie darlings on the rise, they were playing shows at Kilby Court, just like..." />
  <meta name="keywords" content="A&amp;E, Music, Culture" />
  <title>Holiday Weekend Music Update | Buzz Blog</title>

  
  
    <meta name="date" content="2020-05-22 13:30:00" />
  

  
  
  
    <meta name="author" content="Erin Moore">
  

  
  
  <meta name="news_keywords" content="ae, music, culture" />

  
  

  
  
    
  
  
    <link rel="image_src" href="https://media1.fdncms.com/saltlake/imager/u/slideshow/15292190/ritt_momney_at_kilby_court_-_pc_mike_richy.jpg" />
    <meta name="thumbnail" content="https://media1.fdncms.com/saltlake/imager/u/slideshow/15292190/ritt_momney_at_kilby_court_-_pc_mike_richy.jpg" />
  

  
    
      <link rel="canonical" href="https://www.cityweekly.net/BuzzBlog/archives/2020/05/22/holiday-weekend-music-update" />
      <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.cityweekly.net/BuzzBlog/archives/2020/05/22/holiday-weekend-music-update" />
      
    

    
    
    
      
      
      <link rel="amphtml" href="https://www.cityweekly.net/BuzzBlog/archives/2020/05/22/holiday-weekend-music-update?media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="https://www.cityweekly.net/BuzzBlog/archives/2020/05/22/holiday-weekend-music-update" />
    
  

  
    <meta property="fb:app_id" content="358760447552497" />
  

  
  <meta property="og:site_name" content="Salt Lake City Weekly" />
  <meta property="og:title" content="Holiday Weekend Music Update" />

   
  
    

    
    

    
    

    <meta property="og:image" content="https://media1.fdncms.com/saltlake/imager/u/slideshow/15292190/ritt_momney_at_kilby_court_-_pc_mike_richy.jpg" />

    
      <meta property="og:image:width" content="665" />
      <meta property="og:image:height" content="669" />
    
  

  
  
    <meta property="og:description" content="Virtual Fest for S&amp;amp;S Before Ritt Momney got their start as indie darlings on the rise, they were playing shows at Kilby Court, just like..." />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  

    
    

    
    
    

    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media1.fdncms.com/saltlake/imager/u/slideshow/15292190/ritt_momney_at_kilby_court_-_pc_mike_richy.jpg">

    
    

    
      <meta name="twitter:creator" content="@errrands_">
    

    <meta name="twitter:site" content="">
    <meta name="twitter:title" content="Holiday Weekend Music Update">
    <meta name="twitter:description" content="Virtual Fest for S&amp;amp;S Before Ritt Momney got their start as indie darlings on the rise, they were playing shows at Kilby Court, just like...">
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">15292187</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20200522133040</Attribute>
        <Attribute name="creationdate">20200522131522</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20200522133000</Attribute>
            <Attribute name="releasedate">20200522</Attribute>
            <Attribute name="releaseepoch">1590175800</Attribute>
            <Attribute name="title">Holiday Weekend Music Update</Attribute>
            <Attribute name="author">13651595</Attribute>
            <Attribute name="authorname">Erin Moore</Attribute>
            <Attribute name="authorsortname">Moore, Erin</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"https:\/\/www.cityweekly.net\/BuzzBlog\/archives\/2020\/05\/22\/holiday-weekend-music-update"
          },
          "headline": "Holiday Weekend Music Update",
          
            "description": "Virtual Fest for S&amp;S\nBefore Ritt Momney got their start as indie darlings on the rise, they were playing shows at Kilby Court, just like any other small local band.",
          
          
            "image": {
              "url": "https:\/\/media1.fdncms.com\/saltlake\/imager\/u\/original\/15292190\/ritt_momney_at_kilby_court_-_pc_mike_richy.jpg",
              "width": 750,
              "height": 754,
              "@type": "ImageObject"
            },
          
          "datePublished": "2020-05-22T13:30:00",
          "dateModified": "2020-05-22T13:30:40",
          
            "author": {
              "name": "Erin Moore",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Salt Lake City Weekly",
            
              
              
              
              "logo": {
                "url": "https:\/\/www.cityweekly.net\/imager\/b\/google-amp-logo\/808579\/3f42\/slc_fbook.png",
                "width": 380,
                "height": 380,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


</head>





  <body id="Post" class="blog BlogPost BuzzBlog Iapetus10Zone">



<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  
</div><!-- end gridLeader -->

<div id="gridClamp">
  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader BlogPost " style="display:none">
        
        
          Switch to the <a href="https://m.cityweekly.net/BuzzBlog/archives/2020/05/22/holiday-weekend-music-update" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      
      function setRedirectHash() {
        if (location.hash) {
          jQuery("#MobileDetect a[media='handheld']").each(function() {
            var link = jQuery(this);
            link.attr('href', link.attr('href').split('#')[0] + location.hash);
          });
        }
      }
      setRedirectHash();

      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  

<style>
#TopofsiteNoticePressbackers {
 max-width: 100%;
box-sizing: border-box; 
}
</style>

<div class="GlobalHeader BlogPost " id="TopofsiteNoticePressbackers" 
     style="font-size:15px; font-weight: 500; text-align:left; width:930px; padding:10px; margin:20px auto 30px; background-color: #fff;">

<a href="https://pressbackers.com/?page_id=28394" target="_blank"><img src="/binary/4dbf/CITYWEEKLY_350.png" width="350" height="60" alt="" /></a> <br> 

<span style="font-size:20px; font-weight:bold;">We need your help.</span>
<br><br>
Newspapers and media companies nationwide are closing or suffering mass layoffs since the coronavirus impacted all of us starting in March. City Weekly's entire existence is directly tied to people getting together in groups--in clubs, restaurants, and at concerts and events--which are the industries most affected by new coronavirus regulations.
<br><br>
Our industry is not healthy. Yet, City Weekly has continued publishing thanks to the generosity of readers like you. Utah needs independent journalism more than ever, and we're asking for your continued support of our editorial voice. We are fighting for you and all the people and businesses hardest hit by this pandemic.
<br><br>
You can help by making a one-time or recurring donation on <a href="https://pressbackers.com/?page_id=28394" target="_blank" style="font-size:17px; font-weight:800; color:#C02D31;">PressBackers.com</a>, which directs you to our Galena Fund 501(c)(3) non-profit, a resource dedicated to help fund local journalism. It is never too late. It is never too little. Thank you.

<a href="https://pressbackers.com/?page_id=28394" target="_blank" style="display: block;float:right; width:70px;background:#c02d31;border:1px solid #000; color:#fff; font-size:16px; font-weight:700; padding:8px 12px; margin:10px 10px 0px 0px;">
  DONATE
</a>
<div style="clear: both;"></div>
</div>









<div class="clearfix" style="margin-bottom:10px;">
  <div style="float:left;width:728px;height:90px;background:#ccc;text-align:center;line-height:1;margin-right:10px;">
    <!-- /1605976/ROS_728x90_1 -->
          <div id="div-gpt-ad-ros_728x90_1" style="" data-content-type="ad" data-slot="/1605976/ROS_728x90_1" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_728x90_1');
                });
              </script>
          </div>
  </div>
  <div id="dailyFeedIssueBox" style="float:left;">
    
      
        <a href="https://issuu.com/cityweeklynewspaper" target="_blank">
          <img src="/imager/b/coverthisweek/15279268/9cee/CW_1.jpg" 
               alt="Issue Cover"
               width="83" 
               height="90"/>
        </a>

      
      
      <a class="issueBoxLink" href="https://issuu.com/cityweeklynewspaper" target="_blank">
        <img src="/images/header-thisWeek.png" alt="This Week's Issue" />
      </a>
    
  </div>
</div>


  
    


    
    <div id="SearchLogin" class="GlobalHeader BlogPost thedailyfeed clearfix">

      

      
        <div id="logothedailyfeed"><a href="https://www.cityweekly.net/utah/BuzzBlogHome/Page">Buzz Blog</a></div>
      

      <ul id="followUs">
        <li>Follow Us</li>
        <li><a href="https://www.facebook.com/slcweekly" title="Facebook" id="facebook" target="_blank">Facebook</a></li>
        <li><a href="https://twitter.com/cityweekly" title="Twitter" id="twitter" target="_blank">Twitter</a></li>
        <li><a href="https://www.youtube.com/user/SLCityWeekly" title="YouTube" id="youtube" target="_blank">YouTube</a></li>
        <li><a href="https://www.instagram.com/slcweekly/" title="Instagram" id="instagram" target="_blank">Instagram</a></li>
        <!-- <li><a href="http://www.snapchat.com/" title="SnapChat" id="snapchat" target="_blank">SnapChat</a></li> -->
        <li><a href="/utah/SignUp/Page" title="Email" id="email">Email</a></li>
      </ul>

      

      
        

        

        
        <div class="search-wrap">
          <div class="search-link dropdown-link">
            <form class="search-form prepTextForm" id="searchbox_017793458706336421686:nk7zepvg1sm" action="https://www.cityweekly.net/utah/Search">
              <input type="hidden" name="cx" value="017793458706336421686:nk7zepvg1sm" />
              <input type="hidden" name="cof" value="FORID:9" />
              <input type="submit" name="sa" value="Search" />
              <div class="searchElements">
                <input id="search-input" class="searchUpDown" autocomplete="off" type="text"  name="q" size="25" placeholder="" />
              </div>
              <ul id="search-dropdown" class="search-dropdown" style="display:none;">
                <li class="search-option"><a class="search-all" href="https://www.cityweekly.net/utah/Search">All</a></li>
                <li class="search-option"><a href="https://www.cityweekly.net/utah/ArticleArchives">in Articles &amp; Posts</a></li>
                <li class="search-option"><a href="https://www.cityweekly.net/utah/EventSearch">in Events</a></li>
                <li class="search-option"><a href="https://www.cityweekly.net/utah/LocationSearch">in Locations</a></li>
                <li class="search-option"><a href="https://www.cityweekly.net/utah/ArticleArchives" data-category="2125047">in Videos</a></li>
              </ul>
            </form>
          </div>
        </div>

        <script>
        // 
        (function(){
          var searchFormSelector = '#SearchLogin form.search-form';
          var searchInputSelector = '#SearchLogin input#search-input';
          var searchDropdownSelector = '#SearchLogin ul#search-dropdown';
          var searchOptionLinkSelector = '#SearchLogin li.search-option a';

          focusInput = function(e){
            console.log(searchInputSelector);
            jQuery(searchInputSelector).off('focus', focusInput);
            jQuery(document).on('click', blurInput);
            jQuery(searchInputSelector).removeClass("searchUpDown");
            jQuery(searchDropdownSelector).slideDown('fast');
          }

          blurInput = function(e){
            // 
            if( jQuery(e.target).closest(searchFormSelector+', '+searchOptionLinkSelector).length === 0 ) {
              jQuery(document).off('click', blurInput);
              jQuery(searchInputSelector).on('focus', focusInput);
              jQuery(searchInputSelector).addClass("searchUpDown");
              jQuery(searchDropdownSelector).slideUp('fast');
            }
          }

          canProceed = function(){
            return jQuery(searchInputSelector).val() != "";
          }

          enterKeywordMessage = function (){
            jQuery(searchInputSelector).attr('placeholder',"Enter a keyword.");
            window.setTimeout(function(){
              jQuery(searchInputSelector).attr('placeholder',"");
            },1000);
          }

          jQuery(searchInputSelector).on('focus',focusInput);

          // 
          jQuery(searchFormSelector).submit(function(e){
            if(canProceed()){
              console.log('form submitted proceed');
            }else{
              e.preventDefault();
              console.log('form submitted can\'t proceed');
              enterKeywordMessage();
            }
          });

          // 
          jQuery(searchOptionLinkSelector).on('click', function(e){
            e.preventDefault();
            if(canProceed()){
              console.log('link clicked proceed');
              if(jQuery(e.target).hasClass('search-all')){
                jQuery(searchFormSelector).submit();
              } else {
                var newLocation = jQuery(e.target).attr('href') || "";
                var catVal = jQuery(e.target).attr('data-category');
                var catParam = catVal != undefined ? "&category="+catVal : "";
                window.location = newLocation 
                                + "?keywords=" + jQuery(searchInputSelector).val() 
                                + "&submit=Search" 
                                + catParam;
              }
            }else{
              console.log('link clicked can"t proceed');
              enterKeywordMessage();
            }
          });

        })();
        </script> 

      

      
      

      
        
        <ul data-view="loggedin" style="display:none">
          <li><strong data-label="username">Username</strong> / </li>
          <li><a href="https://posting.cityweekly.net/utah/MyProfile">View Profile</a> / </li>
          <li><a href="https://posting.cityweekly.net/utah/Profile/MySettings">Edit Profile</a> / </li>
          <li><a href="https://www.cityweekly.net/utah/Logout">Log Out</a></li>
        </ul>

        <ul data-view="loggedout" style="display:none">
          <li><a href="#LogIn">Log in</a> / </li>
          <li><a href="#CreateAccount">Create Account</a></li>
        </ul>
      

    </div><!-- #SearchLogin -->

    
    
      <script>
        new Foundation.LoginRequiredComponent("SearchLogin");
      </script>
    



  
  

  

  <div id="NavigationHorizontal" class="GlobalHeader BlogPost   thedailyfeed">

  

    

    
    <ul id="mainNav">
      
        <li class="first" id="NavItem_CityWeeklyHomeDailyFeed">
          <a href="https://www.cityweekly.net/utah/Home" target="_self" >Back to Home</a>
        </li>
      

        

        

        

        <li class="last" id="NavItem_TheDailyFeedEvents">
          <a href="https://www.cityweekly.net/utah/EventSearch" target="_self" >Events</a>
        </li>
        
      <li class="first" id="NavItem_Store">
          <a href="https://cwstore.cityweekly.net" target="_blank" class="subnav_link" id="SNAVL_Store">Marketplace</a>
        </li>
    </ul>

    
      
      
        
          <h3 class="hidden">Browse News</h3>
          <ul class="subnav_content" id="SNAV_News" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/cover-story/Category?oid=2125004" target="_self" title="">Cover Stories</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/news/Section?oid=2124970" target="_self" title="">News Features</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/BuzzBlogHome/Page" target="_self" title="">Blogs</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/hits-and-misses/Category?oid=2125005" target="_self" title="">Hits &amp; Misses</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/citizen-revolt/Category?oid=2125020" target="_self" title="">Citizen Revolt</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/opinion/Category?oid=2125013" target="_self" title="">Opinion</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/letters/Category?oid=2125012" target="_self" title="">Soap Box</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/private-eye/Category?oid=2125008" target="_self" title="">Private Eye</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/news-of-the-weird/Category?oid=2927528" target="_self" title="">News of the Weird</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Music</h3>
          <ul class="subnav_content" id="SNAV_Music" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/music/Category?oid=2124997" target="_self" title="">Music Features</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/music-picks/Category?oid=2284307" target="_self" title="">Music Picks</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse A&amp;E</h3>
          <ul class="subnav_content" id="SNAV_Culture" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/arts-and-entertainment/Category?oid=2125059" target="_self" title="">A&amp;E Features</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/entertainment-picks/Category?oid=2284340" target="_self" title="">Entertainment Picks</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/film-reviews/Category?oid=2124987" target="_self" title="">Film Reviews</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/movietimes" target="_blank" title="">Movie Times</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/the-straight-dope/Category?oid=2124996" target="_self" title="">The Straight Dope</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/free-will-astrology/Category?oid=2124993" target="_self" title="">Free Will Astrology</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Best of Utah</h3>
          <ul class="subnav_content" id="SNAV_BestofUtah" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/BestOf?category=2125000&year=2019" target="_blank" title="Best of Utah 2019
Our 30th annual ode to the people, places and businesses that make life in the Beehive State great.">Best of Utah 2019</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/BestofUtahRealEstate/Page" target="_blank" title="">Real Estate</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/BestofUtahBodyMind/Page" target="_self" title="">Body &amp; Mind</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/best-of-utah-2018/BestOf?oid=11652100" target="_blank" title="">Best of Utah 2018</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Marketplace</h3>
          <ul class="subnav_content" id="SNAV_Store" style="display:none;">
        

        

        <li class="">
          <a href="https://cwstore.cityweekly.net/" target="_self" title="">CW Store</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://cwstore.cityweekly.net/Tickets" target="_self" title="">CW Tix</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Eat &amp; Drink</h3>
          <ul class="subnav_content" id="SNAV_restaurantsbars" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/restaurant-reviews/Category?oid=2125003" target="_self" title="">Restaurant Reviews</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/LocationSearch?locationSection=2125344" target="_self" title="">Restaurant Listings</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/food-news/Category?oid=2362594" target="_self" title="">Food News</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/drink/Category?oid=2362670" target="_self" title="">Beer Nerd</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/dining-guide-2019/Content?oid=13609103" target="_self" title="">Dining Guide 2019</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse News</h3>
          <ul class="subnav_content" id="SNAV_News" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/ArticleArchives?category=2125020" target="_self" title="">Citizen Revolt (mobile)</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Things To Read</h3>
          <ul class="subnav_content" id="SNAV_ThingsToRead" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/news/Section?oid=2124970" target="_self" title="">News</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/eat-and-drink/Section?oid=2124971" target="_self" title="">Food &amp; Drink</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/music/Section?oid=2124972" target="_self" title="">Music</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/culture/Section?oid=2124973" target="_self" title="">Culture</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Events</h3>
          <ul class="subnav_content" id="SNAV_ThingsToDo" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/FreeStuff" target="_self" title="">CW Events</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/EventSearch/" target="_self" title="">Events</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Things To Read</h3>
          <ul class="subnav_content" id="SNAV_ThingsToRead" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/news/Section?oid=2124970" target="_self" title="">News</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/eat-and-drink/Section?oid=2124971" target="_self" title="">Food &amp; Drink</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/music/Section?oid=2124972" target="_self" title="">Music</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/culture/Section?oid=2124973" target="_self" title="">Culture</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Things To Do</h3>
          <ul class="subnav_content" id="SNAV_ThingsToDo" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/utah/FreeStuff" target="_self" title="">Promotions</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/EventSearch/" target="_self" title="">Events</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Film</h3>
          <ul class="subnav_content" id="SNAV_Film" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/film-reviews/Category?oid=2124987" target="_blank" title="">Film Reviews</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/movietimes" target="_blank" title="">Movie Times</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/BuzzBlog/archives/sundance-film-festival/" target="_blank" title="">Sundance 2020</a>
        </li>
        
          </ul>
        
      
    

    

    
      
      
        <script>
        (function(){
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
            var navigationID = jQuery(this).attr('id');
            var navigationSelector = '#'+navigationID;
            var navMenuSelector = '#SNAV_'+navigationID.split('_')[1];
            var navigationTimeout;
            var focusNavigation = function(e){
              window.clearTimeout(navigationTimeout);
              jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
              jQuery(navMenuSelector).show();
            }
            var blurNavigation = function(e){
                jQuery(navMenuSelector).hide();
              navigationTimeout = window.setTimeout(function(){
              },75);
            }
            jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
          });
        })();
        </script>
      
    
  

  </div><!-- end navigation -->


  </div><!-- end gridHeader -->

  <div id="gridMain">

    <div id="gridFrame">

      <div id="gridSpanningFeature">
        



  
  
  

  <!-- UIkit CSS -->
  <link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.css?cb=d654bef723a75fb3ce21236a656d9abc" />

  <!-- UIkit JS -->
  <script src="/fdn-system/assets/pub/scripts/uikit.min.js?cb=d654bef723a75fb3ce21236a656d9abc"></script>
  <script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.min.js?cb=d654bef723a75fb3ce21236a656d9abc"></script>


  

  <style>
    @media (min-width: 640px){
      div[id] .uk-child-width-1-3\@exs > * {
         width: calc(100% * 1 / 3.001);
      } 
    }
    #gridMainColumn .uk-width-1-2\@es {
      width: 50%;
    }

    #gridMainColumn .uk-child-width-auto\@exs > * {
      width: auto;
    }
    
    .uk-root {
      font-size: 14px;
    }
  </style>









  
  

  

  

  <div id="BlogHeader" class="SpanningFeature BlogPost  topic_aande BuzzBlog">
    <a href="https://www.cityweekly.net/blogs/BuzzBlog/">
    <h1 class="BuzzBlog">
      
        Buzz Blog
      
    </h1>
    </a>

    

    <p>
      
        <a href="https://www.cityweekly.net/utah/BuzzBlog/blogs/Archives">Archives</a> |
        <a href="/utah/Rss.xml?category=2125738">RSS</a>
      
      
    </p>
  </div>











  
  <link type="text/css" href="/foundation/scripts/jplayer/skin/jplayer.blue.monday.css" rel="stylesheet" />
  <script type="text/javascript" src="/foundation/scripts/jplayer/jquery.jplayer.min.js"></script>               
  
    <style>
    div.jp-audio,
    div.jp-video {
      /* Edit the font-size to counteract inherited font sizing.
       * Eg. 1.25em = 1 / 0.8em
       */
      font-size:1.25em;
    }      
    div.postBody div.inlineAudio,
    div#AudioPlayer div.inlineAudio {
      width: 400px;
      margin: auto;
      clear:both;
      }      
    </style>
  


  <div id="BlogsBlogPost" class="SpanningFeature BlogPost  topicView topic_aande home_follows">

    

    


































    

    
    

    
      
      
        <h2 class="blogDate">Friday, May 22, 2020</h2>
      

      
      <div class="blogPost buzzblog topic-aande topic-music topic-culture">
    
    
      <div class="postCategories">
                
        <span class="postCategory CategoryBuzzBlog">
          <a href="https://www.cityweekly.net/BuzzBlog/archives/aande/" class="topic-aande">A&E</a> / <a href="https://www.cityweekly.net/BuzzBlog/archives/music/" class="topic-music">Music</a> / <a href="https://www.cityweekly.net/BuzzBlog/archives/culture/" class="topic-culture">Culture</a>
        </span>
      </div>
    
    
    <h3 class="postTitle" id="a15292187">
      
      
      
      
      
      
        Holiday Weekend Music Update
      

      
    </h3>

    

    
      <h4 class="postedBy">
        
        <span class="byAttribute">Posted</span>
        
          
          <span class="byAttribute">By</span> <a href="https://www.cityweekly.net/author/erin-moore" rel="author">Erin Moore</a>
        
        
          
            on <span class="postTime"> May 22, 2020</span>, <span class="postTime"> 1:30 PM</span>
          
        
           
      </h4>
    

   
    
    

    
      
        
        















  
  
  

  

  

  
  


        <ul class="horizontalShareTools">
          <li class="l0 first">
            


  
  















  
  
  

  

  

  
  



  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="MicroComponent BlogPost ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:14%; height: 20px; float:left;">
        <fb:like href="https://www.cityweekly.net/BuzzBlog/archives/2020/05/22/holiday-weekend-music-update" send="false" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div> <div class="l0" style="width:14%; height: 20px; float:left;"><a href="https://twitter.com/share?url=https%3A//www.cityweekly.net/BuzzBlog/archives/2020/05/22/holiday-weekend-music-update&text=Holiday%20Weekend%20Music%20Update" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:14%; height: 20px; float:left;">


  

  

  

  <a href="https://pinterest.com/pin/create/button/?description=Holiday%20Weekend%20Music%20Update&amp;media=https%3A%2F%2Fmedia1.fdncms.com%2Fsaltlake%2Fimager%2Fu%2Fslideshow%2F15292190%2Fritt_momney_at_kilby_court_-_pc_mike_richy.jpg&amp;url=https%3A%2F%2Fwww.cityweekly.net%2FBuzzBlog%2Farchives%2F2020%2F05%2F22%2Fholiday-weekend-music-update" class="pin-it-button" count-layout="none">Pin It</a>
  <script>
  Foundation.documentReady.then(function () {
    new Foundation.Script("https://assets.pinterest.com/js/pinit.js", true);
  })
  </script>

</div> <div class="l0" style="width:14%; height: 20px; float:left;">

<a class="emailAction" title="Email" href="https://posting.cityweekly.net/utah/Tools/EmailFriend?oid=15292187" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</div> <div class="l0" style="width:14%; height: 20px; float:left;">

<a class="printAction" title="Print" href="https://www.cityweekly.net/BuzzBlog/archives/2020/05/22/holiday-weekend-music-update?mode=print" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0" style="width:14%; height: 20px; float:left;">


  <a class="toggleActivator saveAction requiresLogin" title="My Favorites" href="https://posting.cityweekly.net/utah/Profile/MyFavorites?add=15292187">
    Favorite
  </a>
  <div class="togglePanel" data-toolsoid="15292187" data-toolsajaxmacro="addObject" style="display:none">
    <div class="loading">Saving&hellip;</div>
    <div class="ajaxUpdater" style="display:none"></div>
  </div>


</div> <div class="l0 last" style="width:14%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=xa-50b3cdf517b9321d" addthis:url="https://www.cityweekly.net/BuzzBlog/archives/2020/05/22/holiday-weekend-music-update" addthis:title="Holiday Weekend Music Update" addthis:description="" class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-50b3cdf517b9321d", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  


          </li>
        </ul>
      
    

    
    

    
    

    <div class="postBody">
      
          
      


      
     
       
      

        

        

        

        

        

        

        
        

        

        

        
      
      
      
      
       
      
      

      
      

      
      
        
        <div class="contentImageCenter" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/saltlake/imager/u/original/15292190/ritt_momney_at_kilby_court_-_pc_mike_richy.jpg" class="zoomable" rel="contentImg_gal-15292187" title="Ritt Momney - MIKE RICHY">                  <img src="https://media1.fdncms.com/saltlake/imager/u/blog/15292190/ritt_momney_at_kilby_court_-_pc_mike_richy.jpg?cb=1590175605" width="665" height="669" alt="Ritt Momney - MIKE RICHY" srcset="" />                </a>                                                                                                           <ul style="width:665px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                          <li class="imageCredit">                                              Mike Richy                                          </li>                                                                                                                            <li class="imageCaption">                      Ritt Momney                    </li>                                                                                                </ul>                                                       </div>

<b>Virtual Fest for S&amp;S</b><br>
Before Ritt Momney got their start as indie darlings on the rise, they were playing shows at Kilby Court, just like any other small local band. Now, from their new locale in Los Angeles, they’re paying it forward to Kilby by organizing Virtual Fest, an online streaming festival featuring a roster full of Utah-based artists starting at 4 p.m. this Sunday, May 24. Though there’s no door fee—since there’s no door to walk through—those who watch are encouraged to donate to S&amp;S, knowing that they also can redeem that money for future tickets and a t-shirt. Without the constraints of a physical venue, live-stream events like this have the potential to feature many different artists, and this one takes advantage of that freedom. Twelve local acts will play (roughly) 15-minute sets, starting out with Ellee Duke and moving onto Anaïs Chantal, Courtney Lane, Kipper Snack, Brother., Dad Bod, The Rubies, Blue Rain Boots, The Moss, Joshua James, The Backseat Lovers and finally Ritt Momney themselves at 7:15 p.m. It’s a veritable deluge of well-known talent from around Salt Lake City and Utah County, and will all go down on <a href="https://www.youtube.com/channel/UCd7OtTy4s4swX4891VbF3Hg" target="_blank">Ritt Momney's YouTube channel</a>. Find the event page, links and info on donating up at <a href="http://www.facebook.com/kilbycourtSLC" target="_blank">Kilby Court’s Facebook page</a>. 

            
          
            <br>
<br>
<b>Symphony Sounds on Classical 89</b><br>
Music lovers of all genres are suffering right now. With live concert attendance still in the distant future, music makers and shakers are keeping the sounds alive, virtually. The Utah Symphony has teamed up with Classical 89 to offer broadcasts of their live recordings from past performances, from 9 a.m. and 2 p.m. weekdays and at 9:30 a.m. Saturdays. Lovers of classical music can enjoy the symphony morning, noon and night all week long, and check in on the upcoming programming at classical89.org under the Utah Symphony tab. Not only are they rebroadcasting classic works, but the recordings feature some big names like Karina Canellakis, Boris Giltburg and Phillipe Quint. Expect beloved classical pieces from Bach, Tchaikovsky, Chopin, Beethoven and many more. And whether you’re a fan of the classics or not, there is something to be said of starting your morning with a strong cup of coffee and a violin concerto—especially if you’re missing Coffee Garden hangs, where that pairing is pleasantly ever-present. If you miss the rebroadcasts, more recordings from the Utah Symphony are available at <a href="http://utahsymphony.org/explore/playlists/listening-room" target="_blank">Utah Symphony's listening room</a>, which is otherwise another great resource for finding entertainment while stuck in quarantine—they’ve even got “quarantunes.” 

            
          
            <br>
<br>

<div class="contentImageRight" style="overflow:hidden;">                                        <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/saltlake/imager/u/original/15292191/shit_jewelry_show_poster.jpg" class="zoomable" rel="contentImg_gal-15292187" title="">                  <img src="https://media1.fdncms.com/saltlake/imager/u/blog/15292191/shit_jewelry_show_poster.jpg?cb=1590175821" width="250" height="247" alt="shit_jewelry_show_poster.jpg" srcset="" />                </a>                                                                                                           <ul style="width:250px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>

<b>Shit Jewelry is a  Placeless Place for People</b><br>
When shows started first happening on shitjewelry.com at the beginning of quar, it was just a web page with a show poster on it and a link to a YouTube page. Upon visiting again in anticipation of this Saturday’s (May 23) upcoming show, you can see that it’s undergone some apparent developments. Now the YouTube videos are embedded in the page, and will, I’m guessing, contain the video when the show goes live at 8 p.m. The show poster is dated to an old one, because the real upcoming set features Cupid Come, Petr Chubak and Rebel Rebel. As they have since the beginning, there’s encouragement to “tip the engineer babes,” those who helped make the page possible, listed as Kale, Gray, Nate, Tommy and Chuck with the Venmo address @summertimenate listed for tippers to use. Most interestingly on the still rather spare web page, though, is a quote by Judith Butler from her book Precarious Life (Butler is one of the foremost gender philosophers of the last 30 years for those who aren’t savvy). It reads, “When we undergo what we do, something about who we are is revealed, something that delineates the ties we have to others, that shows us that these ties constitute what we are, ties or bonds that compose us.” Below this quote—which already brings to mind the struggle of social connection these days—there are some vague notes, seemingly from the page engineers themselves, that read: 

            
          
            <br>
<br>
“Thinking about libertarians forgetting about being vulnerable and beholden to others, about the team sport that is living. A babe needs a mom. My great grandma needs my aunt to bring the groceries, needs the dogs to talk to. I need a job from someone. You need another person’s voice to dance with … Insane how the non-living virus creates a microbiological relationship with each of us, forming new combinations. There’s also combinations where the virus is not there. Where Someone In Particular is not there. Who are we again? Can’t wait for some other me to see some other you.” 

            
          
            <br>
<br>
Live streams are somewhat awkward in my view, a shadow of the real thing. But this little note throws into perspective that at least it’s something, a vital connection, a simple “voice to dance with.” Shit Jewelry, clearly, is anything but shit. Keep up with Shit Jewelry show info on <a href="https://www.instagram.com/shit.jewelry/" target="_blank">Instagram</a>.
      
      
      <div class="clearfix"></div>
      
      
      
    </div>

    
    
    

    

    

    

  </div> <!-- end blogPost -->
    
    <div class="clear"></div>
  </div>














































  

  

  
  

  
  

  
     

     

  
  

  
  


  

  
  
  


  

  



  

  

  
  






  

  

  
  

  
    
  

  








  
  

  <div id="BlogsPreviousNext" class="SpanningFeature BlogPost ">
    <div class="prevNext">
      
        <a href="https://www.cityweekly.net/BuzzBlog/archives/2020/05/21/movie-reviews-new-releases-for-may-22" class="prev" rel="prev">&laquo;&nbsp;Movie Reviews: New Releases for May&hellip;</a>
        
    </div>
  </div>




















    
    
    
    



























  
  

  
  


<div class="SpanningFeature BlogPost " ID="TellMeMore">
  <a href="https://www.cityweekly.net/utah/memberships/Page" target="_blank"><img src="/binary/c1bb/Olympian-Tell-Me-More.png" width="667" height="183" alt="" /></a>
</div>

<script type="text/javascript">
  function setBioLink(){
    jQuery(".bio .readMore").click(function(e){
      e.preventDefault();
      var elem = jQuery(this);
      if (elem.prevAll(".authorBioLong").is(":hidden")){
        elem.prevAll(".authorBioShort").fadeOut("fast", function(){
          elem.prevAll(".authorBioLong").fadeIn("fast");
          elem.html("less");
        });          
      } else {
        elem.prevAll(".authorBioLong").fadeOut("fast", function(){
          elem.prevAll(".authorBioShort").fadeIn("fast");                   
          elem.html("more");
        });          
      }
    })
  }
</script>





  <div id="AbouttheauthorWrapper" class="SpanningFeature BlogPost Wrapper">
  
    <div id="Abouttheauthor" class="SpanningFeature BlogPost  clearfix">
      
        <h3><span class="headingText">About The Author</span></h3>
        
      <a href="https://www.cityweekly.net/author/erin-moore">
      
        
        <img src="/imager/b/story/13651595/def1/unnamed-4.jpg" border="0" width="200" height="150" alt="Erin Moore" />
      
      </a>
      <a href="https://www.cityweekly.net/author/erin-moore"><h4>Erin Moore</h4></a> 

      
        
          <div class="email"><a href="mailto:music@cityweekly.net">music@cityweekly.net</a></div>
        
      
    
      

      
        <div class="twitter"><a href="https://twitter.com/errrands_" target="_blank">@errrands_</a></div>
      
    
      

      
        <div class="bio">
          <span class="label"><b>Bio:</b><br /></span>
          
            Erin Moore is <i>City Weekly</i>'s music editor. Email tips to: music@cityweekly.net.
                  
        </div>
      
    
    </div> <!-- Abouttheauthor -->
  
  </div>
  
  <script type="text/javascript">
  Foundation.documentReady.then(function () {
    var twitterLinkSelector = '#Abouttheauthor div.twitter a';
    jQuery(twitterLinkSelector).each(function(){
      jQuery(this).clone().insertAfter(this).addClass('twitter-follow-button').removeClass('twitter').attr('data-show-count','true').attr('data-lang','en').attr('data-show-screen-name','false');
    });
    (new Foundation.Script("https://platform.twitter.com/widgets.js", true)).then(function () {
      !function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");
      });
  });
  </script>

<script>setBioLink();</script>












  
  
      <div id="RecentbyTopic" class="SpanningFeature BlogPost ">
        <h3 class="latest">
          <span class="headingText">
          
            On Topic...
                
          </span>
        </h3>
        
        <ul class="moduleList">
    
    
    
    

    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/BuzzBlog/archives/2020/05/19/kings-english-hosts-virtual-conversation-with-john-grisham">King's English hosts virtual conversation with John Grisham</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Scott Renshaw</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May 19, 2020</span>
        </li>
      
    </ul>
  </li>

    
  
    
    
    

    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/BuzzBlog/archives/2020/05/19/music-update-utah-symphony-80th-anniversary-online-madeleine-choir-school">Music Update: Utah Symphony 80th Anniversary Online, Madeleine Choir School</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Erin Moore</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May 19, 2020</span>
        </li>
      
    </ul>
  </li>

    
  
    
    
    

    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/BuzzBlog/archives/2020/05/14/movie-reviews-new-releases-for-may-15">Movie Reviews: New Releases for May 15</a>
    </h4>
    
      <h5 class="subhead">
        The Vast of Night, Clementine, Up from the Streets and more
      </h5>
    
    <ul>
      
        <li class="l1 byline">by Scott Renshaw</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May 14, 2020</span>
        </li>
      
    </ul>
  </li>

    
  
      
        <li class="l0 storyItem">
          
          
            
             <a href="https://www.cityweekly.net/BuzzBlog/archives/a%26e/" class="more">More A&E &raquo;</a>
            
             <a href="https://www.cityweekly.net/BuzzBlog/archives/music/" class="more">More Music &raquo;</a>
            
             <a href="https://www.cityweekly.net/BuzzBlog/archives/culture/" class="more">More Culture &raquo;</a>
            
          
          
        </li>
      
        </ul>
      </div>
    
  









  

  

  
    <div id="MorebyThisAuthorWrapper" class="SpanningFeature BlogPost Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="SpanningFeature BlogPost ">
            <h3><span class="headingText">More by Erin Moore</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/utah/staying-power/Content?oid=15282867">Staying Power</a>
    </h4>
    
      <h5 class="subhead">
        Music venues are forced to stand together to survive the economic cost of the pandemic
      </h5>
    
    <ul>
      
        <li class="l1 byline">by Erin Moore</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May 20, 2020</span>
        </li>
      
    </ul>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/BuzzBlog/archives/2020/05/19/music-update-utah-symphony-80th-anniversary-online-madeleine-choir-school">Music Update: Utah Symphony 80th Anniversary Online, Madeleine Choir School</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Erin Moore</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May 19, 2020</span>
        </li>
      
    </ul>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/BuzzBlog/archives/2020/05/11/state-room-poster-project-fundraiser">State Room "Poster Project" Fundraiser</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Erin Moore</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May 11, 2020</span>
        </li>
      
    </ul>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.cityweekly.net/utah/ArticleArchives?author=13651595" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  










  
  
      <div id="LatestInCategory" class="SpanningFeature BlogPost ">
        <h3 class="latestbuzz_blog"><span class="headingText">Latest in Buzz Blog</span></h3>
        <ul class="moduleList ui list grouped expanded">
    
    
    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/BuzzBlog/archives/2020/05/21/movie-reviews-new-releases-for-may-22">Movie Reviews: New Releases for May 22</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Scott Renshaw</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May 21, 2020</span>
        </li>
      
    </ul>
  </li>
    
  
    
    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/BuzzBlog/archives/2020/05/20/aid-to-the-navajo-nation">Aid to the Navajo Nation</a>
    </h4>
    
      <h5 class="subhead">
        Ogden's Own Distillery donates 485 gallons of sanitizer to Navajo Nation
      </h5>
    
    <ul>
      
        <li class="l1 byline">by Mikey Saltas</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May 20, 2020</span>
        </li>
      
    </ul>
  </li>
    
  
    
    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/BuzzBlog/archives/2020/05/19/kings-english-hosts-virtual-conversation-with-john-grisham">King's English hosts virtual conversation with John Grisham</a>
    </h4>
    
    <ul>
      
        <li class="l1 byline">by Scott Renshaw</li>
      
      
        <li class="l1 longOnly">
          <span class="date">May 19, 2020</span>
        </li>
      
    </ul>
  </li>
    
  
        
            <li class="l0 storyItem more">
              <a href="https://www.cityweekly.net/utah/ArticleArchives?category=2125738" class="more">More &raquo;</a>
            </li>
          </ul>
        
      </div>
    








  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  

  
  


  

  
    
      <style>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</style>
      <div id="BlogComments" class="SpanningFeature BlogPost CommentsComponent ">
        
        
        <div class="commentsHeader hreview-aggregate clearfix" id="readerComments">

          
          
          
          <h3 class="clearfix">
            <div style="float:left;">
              Comments 
            </div>
            
          </h3>
        </div>
        
        
        <div id="BlogComments_commentContent" class="commentContent">
          
        </div>
        

        
          <div class="bottomOptionBar clearfix">
            
              <div style="float:left;">
      <div style="float:left;margin:4px 0; padding:4px 6px;">Subscribe to this thread:</div>
      <div style="position:relative;float:left">
      <div class="commentSubscribeLink">
        <a class="toggleActivator saveAction" id="doSubscribe" href="javascript://Subscribe">By Email</a>
      </div>
      <div class="togglePanel" data-toolsoid="15292187" data-toolsajaxmacro="commentSubscribe" style="display:none">
        <div class="toggleArrowBorder"></div>
        <div class="toggleArrow"></div>
        <a href="javascript://close" class="togglePanelClose"><img src="/foundation/images/icons/cross.png" width="14" height="14"></a>
        <div class="loading">Subscribing&hellip;</div>
        <div class="ajaxUpdater" style="display:none;"></div>
      </div>
      </div>
      <div class="commentRSSLink"><a href="/utah/Rss.xml?id=comments&amp;oid=15292187" class="feedLink" title="Subscribe to this story's comments" target="_blank">With RSS</a></div>
      </div>
            
            
          </div>          
          
        <hr />

        

        
          

          <form id="BlogCommentsPostCommentForm" method="post" class="userCommentForm validateForm" data-validate="login" data-validate-login-options="{&quot;feelingShy&quot;:false}">
            <input type="hidden" name="commentType" value="comment" />
            <input type="hidden" name="oid" value="15292187" />
            <input type="hidden" name="source" value="desktop">

            
            

            <label for="comment" class="hidden">Comment</label>
            
              <h4 class="commentFormAddHeader"><a name="readerComments">Add a comment</a></h4>
            

            
            
            

            <div class="errorDisplay" style="display:none">
              <ol></ol>
            </div>
            <dl class="formElements clearfix">
            
              <dd><textarea name="comment" style="height:112px;overflow:hidden;" tabindex="1" class="expandableBox required" id="comment" data-validate="required"></textarea></dd>
            </dl>

            

            

            <input type="checkbox" name="subscribe" id="BlogComments_commentSubscribe" value="yes"> <label for="BlogComments_commentSubscribe" style="margin-right:24px;">Subscribe to this thread</label>
            
            

            <p class="commentFormSubmit">
              <input type="submit" name="commentSubmit" tabindex="2" value="Post Comment" id="commentSubmit" />
            </p>

          </form>
          <script>
            jQuery("textarea.expandableBox").autoBoxResize();
          </script>
        
      </div><!-- comments -->
      <script type="text/javascript">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</script>
    
  

<div id="AdBottomTwo300x250" class="SpanningFeature BlogPost ads ">
  <!-- /1605976/ROS_300x250_6 -->
          <div id="div-gpt-ad-ros_300x250_6" style="" data-content-type="ad" data-slot="/1605976/ROS_300x250_6" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_300x250_6');
                });
              </script>
          </div>
  <!-- /1605976/ROS_300x250_7 -->
          <div id="div-gpt-ad-ros_300x250_7" style="" data-content-type="ad" data-slot="/1605976/ROS_300x250_7" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_300x250_7');
                });
              </script>
          </div>
</div><!-- #AdBottomTwo300x250 -->​<div id="StanzaJazzCalendar" class="SpanningFeature BlogPost ">
  

    <div class="stanzacal" data-stanzacal="slcweekly" data-site="cityweekly" data-width="100%" data-height="250px"></div>
    <script src="https://dff2h0hbfv6w4.cloudfront.net/scripts/embed-stanzacal-v1.js" type="text/javascript"></script>

    
  
</div>






      </div><!-- gridSpanningFeature -->
      
      <div id="gridSpanningFeature2">
        


  

  

  
  

  
    
  

  















    
    
    
    



























  
  

  
  






      </div><!-- gridSpanningFeature2 -->

      <div id="gridColumnContainer" class="clearfix">

        <div id="gridMainColumn1">
          
        </div><!-- gridMainColumn1 -->
        
        <div id="gridMainColumn2">
          
        </div><!-- gridMainColumn2 -->

      </div><!-- end gridColumnContainer -->

    </div><!-- end gridFrame -->

    <div id="gridRightColumn">   
      <div id="gridSpanningIsland">
        <div id="Promotionslink" class="SpanningIsland BlogPost ">
<a href="https://www.cityweekly.net/utah/FreeStuff" target="_blank">Promotions</a>
</div>
 <div id="MovieTimesLink" class="SpanningIsland BlogPost ">
   <a href="https://www.cityweekly.net/utah/MovieTimes"><img src="/general/graphics/MovieTimesTicket.png" border="0" title="Movie Times" alt="Movie Times"></a>
  </div>



<style>#WhatsHappeningWidget {width:300px;margin:1em auto;}</style>




   
    <div id="WhatsHappeningWidget" class="SpanningIsland BlogPost Widget">
         
       <script type="text/javascript" src="//portal.CitySpark.com/WidgetScripts/8028" > </script>
       
    </div>  
     
    


    
<div id="Ad300x250x1" class="SpanningIsland BlogPost ">
  <!-- /1605976/ROS_300x250_1 -->
          <div id="div-gpt-ad-ros_300x250_1" style="" data-content-type="ad" data-slot="/1605976/ROS_300x250_1" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_300x250_1');
                });
              </script>
          </div>
</div><!-- #Ad300x250x1 --><div id="Ad300x250x2" class="SpanningIsland BlogPost ">
  <!-- /1605976/ROS_300x250_2 -->
          <div id="div-gpt-ad-ros_300x250_2" style="" data-content-type="ad" data-slot="/1605976/ROS_300x250_2" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_300x250_2');
                });
              </script>
          </div>
</div><!-- #Ad300x250x2 --><div id="TheSocialWidget" class="SpanningIsland BlogPost ">
  
    <div class="header" style="display:block;text-align:center;"><img src="/binary/9c5c/thesocial.jpg" width="300" height="62" alt="" /></div>
    <iframe src="https://cityweekly.friends2follow.com/f2f/widget/html/socialstack/101/0/12/160/1-4/1/1" frameborder="0" height="600" width="300" scrolling="no"></iframe>
  
</div><div id="Ad300x250x3" class="SpanningIsland BlogPost ">
  <!-- /1605976/ROS_300x250_3 -->
          <div id="div-gpt-ad-ros_300x250_3" style="" data-content-type="ad" data-slot="/1605976/ROS_300x250_3" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_300x250_3');
                });
              </script>
          </div>
</div><!-- #Ad300x250x3 --><div id="Ad300x250x4" class="SpanningIsland BlogPost ">
  <!-- /1605976/ROS_300x250_4 -->
          <div id="div-gpt-ad-ros_300x250_4" style="" data-content-type="ad" data-slot="/1605976/ROS_300x250_4" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_300x250_4');
                });
              </script>
          </div>
</div><!-- #Ad300x250x4 --><div id="Ad300x250x5" class="SpanningIsland BlogPost ">
  <!-- /1605976/ROS_300x250_5 -->
          <div id="div-gpt-ad-ros_300x250_5" style="" data-content-type="ad" data-slot="/1605976/ROS_300x250_5" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_300x250_5');
                });
              </script>
          </div>
</div><!-- #Ad300x250x5 -->

<div id="SocialStack" class="SpanningIsland BlogPost ">
      
    <div class="header" style="display:block;background-color:#e9e9e9;text-align:center;padding:10px;"><img src="/binary/bc2c/staffSocial.png" width="280" height="90" alt="" /></div>
    <iframe src="https://cityweekly.friends2follow.com/f2f/widget/html/socialstack/50/0/12/160/1-4/1" frameborder="0" height="600" width="300" scrolling="no"></iframe>
    <center><span style="font-size:40px;  color:#66798F">
      <a href="https://www.facebook.com/slcweekly" target="_blank" style="text-decoration:none;">&middot;&middot;&middot;</a>
     </span></center>
</div>
      </div><!-- end gridSpanningIsland -->  
     
      <div id="gridMainSidebar">
        
      </div><!-- end gridMainSidebar -->

      <div id="gridAdSidebar">
        
      </div><!-- end gridAdSidebar -->
      
      <div id="gridBottomSidebar">
        
      </div>
    </div><!-- end gridRightColumn -->
    
    <!-- Footer -->
    <div id="gridFooter">
      


    <div id="FooterNavigation" class="GlobalFooter BlogPost ">
      <ul>
  
  
  <li class="">
    <a href="https://www.cityweekly.net/utah/Home" target="_self">
      
        Home
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/AboutUs/Page" target="_self">
      
        Who We Are
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/ContactUs/Page" target="_self">
      
        Contact
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/Circulation/Page" target="_self">
      
        Circulation
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/WorkWithUs/Page" target="_self">
      
        Work With Us
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/Advertising/Page" target="_self">
      
        Advertising
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/SignUp/Page" target="_blank">
      
        Newsletters
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/special-guides/Section?oid=2124976" target="_self">
      
        Guides
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/IssueArchives?year=2019" target="_blank">
      
        E-Weekly
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/IssueArchives" target="_self">
      
        Issue Archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/PrivacyPolicyTermsofUse/Page" target="_self">
      
        Privacy Policy / Terms of Use
      
    </a>
    
    
  </li> 
  

      </ul>
    </div>
  





<div id="footerCopyright">
  <p>
   &copy; 2020
    
      Salt Lake City Weekly 
     
   <br><br>
   Website powered by <a href="https://www.publishwithfoundation.com/" target="_blank">Foundation</a>
  </p>
</div>





<!-- GOOGLE ANALYTICS -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-24101179-1', 'auto');
  ga('send', 'pageview');

var trackOutboundLink = function(url) {
   ga('send', 'event', 'outbound', 'click', url, {
     'transport': 'beacon',
     'hitCallback': function(){document.location = url;}
   });
}

</script>

<!-- END GOOGLE ANALYTICS -->





<!-- QUANTCAST TRACKING CODE --> 

<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-a4LDpi_DEopn-"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
 
<!-- END QUANTCAST  -->


  <img src="/foundation/images/icons/pixel.gif?oid=15292187" alt="" />


    </div><!-- end gridFooter -->

  </div><!-- end gridMain -->

</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  <div id="AdFixedLeaderboard728x90" class="Closer BlogPost ">
  <!-- /1605976/FixedLeaderboard -->
          <div id="div-gpt-ad-fixedleaderboard" style="" data-content-type="ad" data-slot="/1605976/FixedLeaderboard" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-fixedleaderboard');
                });
              </script>
          </div>

  
  
    
    <script>
    jQuery('div#div-gpt-ad-fixedleaderboard').append(jQuery('<div class="closeButt">❌</div>'))
    jQuery('div#div-gpt-ad-fixedleaderboard div.closeButt').click(function(){
      jQuery('div#div-gpt-ad-fixedleaderboard').hide()
    })
    </script>
</div>
</div><!-- end gridCloser -->
    </body>
</html>
  


