































































  
           
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "https://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="https://www.w3.org/1999/xhtml" xmlns:fb="https://www.facebook.com/2008/fbml" xml:lang="en" lang="en">

<head>
  
  <meta name="viewport" content="width=1000">

  
  <meta name="layout" content="Blog Post" />
  
    <meta name="oid" content="17695177" />
  
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
  <meta http-equiv="imagetoolbar" content="no" />
  <meta http-equiv="X-UA-Compatible" content="IE=edge" />

  
  
  
  <link rel="stylesheet" type="text/css" href="/foundation/styles/reset.css?cb=1d2764a5317b12a6f315f96add1dbf06" />
  <link rel="stylesheet" type="text/css" href="/styles/defaults.css?cb=1d2764a5317b12a6f315f96add1dbf06" />
  <link rel="stylesheet" type="text/css" href="/styles/components.css?cb=1d2764a5317b12a6f315f96add1dbf06" />
  <link rel="stylesheet" type="text/css" href="/styles/publication.css?cb=1d2764a5317b12a6f315f96add1dbf06" />

  
  
    <script src="/foundation/fontawesome/js/brands.min.js" async></script>
    <script src="/foundation/fontawesome/js/solid.min.js" async></script>
    <script src="/foundation/fontawesome/js/regular.min.js" async></script>
    <script src="/foundation/fontawesome/js/fontawesome.min.js" async></script>
    <script src="/foundation/fontawesome/js/light.min.js" async></script>
    <script src="/foundation/fontawesome/js/duotone.min.js" async></script>
  

  <style type="text/css">
    /* Foundation Convenience Styles */
    /* For programmatic usage only! */
    .clear { clear: both }
    .hidden { display: none }
    .lower { text-transform: lowercase }
    .upper { text-transform: uppercase }

    /* Foundation Conditional Display Classes */
    .briefOnly     {  }    /* override in components.css */
    .longOnly      {  }    /* override in components.css */
  </style>

  
    <link rel="stylesheet" type="text/css" href="/foundation/grids/iapetus-10-zone.css" />
  

  <!--[if lte IE 6]>
    <link rel="stylesheet" type="text/css" href="/styles/ie6.css" />
  <![endif]-->
  <!--[if IE 7]>
    <link rel="stylesheet" type="text/css" href="/styles/ie7.css" />
  <![endif]-->
  <!--[if IE 8]>
    <link rel="stylesheet" type="text/css" href="/styles/ie8.css" />
  <![endif]-->
  <!--[if gte IE 9]>
      <link rel="stylesheet" type="text/css" href="/styles/ie9-plus.css">
  <![endif]-->

  <link rel="stylesheet" href="/styles/print.css" type="text/css" media="print" />

  
  
    
    
      <link rel="alternate" type="application/rss+xml" title="Salt Lake City Weekly RSS: Whole Site" href="https://www.cityweekly.net/utah/Rss.xml" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Salt Lake City Weekly RSS: Blog Section" href="https://www.cityweekly.net/utah/Rss.xml?oid=2125737" />
    
    
      <link rel="alternate" type="application/rss+xml" title="Salt Lake City Weekly RSS: Buzz Blog" href="https://www.cityweekly.net/utah/Rss.xml?oid=2125738" />
      
        <link rel="alternate" type="application/rss+xml" title="Salt Lake City Weekly RSS: Buzz Blog: " href="https://www.cityweekly.net/utah/Rss.xml?category=2125738&amp;topic=oid%3A2125752" />
      
    

    
    
      <link rel="alternate" type="application/rss+xml" title="Salt Lake City Weekly RSS: Comments on Buzz Blog" href="https://www.cityweekly.net/utah/Rss.xml?id=comments&amp;oid=2125738" />
      
        <link rel="alternate" type="application/rss+xml" title="Salt Lake City Weekly RSS: Comments on Buzz Blog: " href="https://www.cityweekly.net/utah/Rss.xml?category=2125738&amp;id=comments&amp;topic=oid%3A2125752" />
      
    
  

  

  
    <script>window.__FBAPIv__ = 'v3.2'</script>
  

  
  
    <!--[if lte IE 8]>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/es5-shim/4.5.7/es5-shim.min.js"></script>
        <script src="https://cdnjs.cloudflare.com/ajax/libs/json3/3.3.2/json3.min.js"></script>
      <![endif]-->
      
      <script>
        if (!window.Promise) document.write('<scr'+'ipt src="https://cdnjs.cloudflare.com/ajax/libs/native-promise-only/0.8.1/npo.src.js"></scr'+'ipt>')
      </script>
    
    
    
    
    <script src="/foundation/scripts/common.js?cb=afb71ccca4d3b05498039dabda50cc83"></script>
  
    
    
    
    
    
    
    <script src="/foundation/scripts/desktop-bundle.js?cb=afb71ccca4d3b05498039dabda50cc83"></script>
  

  
  <link rel="stylesheet" href="/foundation/styles/fancybox/jquery.fancybox-1.3.4.css" type="text/css" media="screen" />
  <script>
    Foundation.documentReady.then(function () {
        jQuery("a.zoomable").fancybox({"type": "image", "titlePosition": "over"});
    });
  </script>

  
  
  

  
  <script>
    // Smooth scrolling to anchors on the same page.
    setupGlide();
    
    // Modify user's own profile links to go to correct URL.
    fixupProfileLinks("https:\/\/www.cityweekly.net\/utah\/Profile", "https:\/\/posting.cityweekly.net\/utah\/MyProfile");
  </script>
  
  
  

  
  
    <meta name="google-signin-client_id" content="994967671027-8onjgidd96k7ia5node65hqvciq4ko73.apps.googleusercontent.com">
  

    
  

  
  <!-- Begin Google Web Font API Call -->
<link href='https://fonts.googleapis.com/css?family=Fjalla+One|Yanone+Kaffeesatz:700|Playfair+Display:400,700' rel='stylesheet' type='text/css'>
<!-- End Google Web Font API Call -->

<script type='text/javascript'>
            var googletag = googletag || {};
            googletag.cmd = googletag.cmd || [];
            (function() {
              var gads = document.createElement('script');
              gads.async = true;
              gads.type = 'text/javascript';
              var useSSL = 'https:' == document.location.protocol;
              gads.src = (useSSL ? 'https:' : 'http:') + '//securepubads.g.doubleclick.net/tag/js/gpt.js';
              var node = document.getElementsByTagName('script')[0];
              node.parentNode.insertBefore(gads, node);
            })();
          </script>
          <script type='text/javascript'>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</script>

<!-- Initiate Chartbeat tracking Also see code at end of body  -->
<script type="text/javascript">var _sf_startpt=(new Date()).getTime()</script>
<!-- End Chartbeat initiating code -->








<!-- Facebook Pixel Code -->
<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
 fbq('init', '1832028880415856'); 
fbq('track', 'PageView');
</script>
<noscript>
 <img height="1" width="1" 
src="https://www.facebook.com/tr?id=1832028880415856&ev=PageView
&noscript=1"/>
</noscript>
<!-- End Facebook Pixel Code -->
  
  
  
  
  


  
  
  


  
  <link rel="shortcut icon" href="/favicon.ico" />
  <meta name="title" content="Music Update Dec. 17 | Buzz Blog" />
  <meta name="description" content="New music from Patrick Buie, December 12 Minutes Max" />
  <meta name="keywords" content="A&amp;E, Music, Culture" />
  <title>Music Update Dec. 17 | Buzz Blog</title>

  
  
    <meta name="date" content="2021-12-17 11:19:00" />
  

  
  
  
    <meta name="author" content="Erin Moore">
  

  
  
  <meta name="news_keywords" content="ae, music, culture" />

  
  

  
  
    
  
  
    <link rel="image_src" href="https://media1.fdncms.com/saltlake/imager/u/slideshow/17695181/patrick_buie_s_precious_time_single_art.png" />
    <meta name="thumbnail" content="https://media1.fdncms.com/saltlake/imager/u/slideshow/17695181/patrick_buie_s_precious_time_single_art.png" />
  

  
    
      <link rel="canonical" href="https://www.cityweekly.net/BuzzBlog/archives/2021/12/17/music-update-dec-17" />
      <link rel="alternate" media="only screen and (max-width: 640px)" href="https://m.cityweekly.net/BuzzBlog/archives/2021/12/17/music-update-dec-17" />
    

    
    
    
      
      
      <link rel="amphtml" href="https://www.cityweekly.net/BuzzBlog/archives/2021/12/17/music-update-dec-17?media=AMP+HTML" />
    
  

  
    
      <meta property="og:url" content="https://www.cityweekly.net/BuzzBlog/archives/2021/12/17/music-update-dec-17" />
    
  

  
    <meta property="fb:app_id" content="358760447552497" />
  

  
  <meta property="og:site_name" content="Salt Lake City Weekly" />
  <meta property="og:title" content="Music Update Dec. 17" />

   
  
    

    
    

    
    

    <meta property="og:image" content="https://media1.fdncms.com/saltlake/imager/u/slideshow/17695181/patrick_buie_s_precious_time_single_art.png" />

    
      <meta property="og:image:width" content="665" />
      <meta property="og:image:height" content="663" />
    
  

  
  
    <meta property="og:description" content="New music from Patrick Buie, December 12 Minutes Max" />
  

  
  

  
  
    <meta property="og:type" content="article" />
  

  
  

    
    

    
    
    

    
      <meta name="twitter:card" content="summary_large_image">
      <meta name="twitter:image" content="https://media1.fdncms.com/saltlake/imager/u/slideshow/17695181/patrick_buie_s_precious_time_single_art.png">

    
    

    
      <meta name="twitter:creator" content="@errrands_">
    

    <meta name="twitter:site" content="@CityWeekly">
    <meta name="twitter:title" content="Music Update Dec. 17">
    <meta name="twitter:description" content="New music from Patrick Buie, December 12 Minutes Max">
  

  
  
  <!--
    <PageMap>
      <DataObject type="foundation">
        <Attribute name="oid">17695177</Attribute>
        <Attribute name="class">Content</Attribute>
        <Attribute name="lastmodified">20211217112005</Attribute>
        <Attribute name="creationdate">20211217111542</Attribute>
      </DataObject>

      
        
          <DataObject type="document">
            <Attribute name="releasedatetime">20211217111900</Attribute>
            <Attribute name="releasedate">20211217</Attribute>
            <Attribute name="releaseepoch">1639765140</Attribute>
            <Attribute name="title">Music Update Dec. 17</Attribute>
            <Attribute name="author">13651595</Attribute>
            <Attribute name="authorname">Erin Moore</Attribute>
            <Attribute name="authorsortname">Moore, Erin</Attribute>
          </DataObject>
        

        
      
    </PageMap>
  -->


  
  
  
  
    
    <script type="application/ld+json">
        {
          "mainEntityOfPage": {
            "@type": "WebPage",
            "@id":"https:\/\/www.cityweekly.net\/BuzzBlog\/archives\/2021\/12\/17\/music-update-dec-17"
          },
          "headline": "Music Update Dec. 17",
          
            "description": "Patrick Buie releases “Precious Time”\nA few months after his woozy and dreamy single “(Tell Me) What Went Wrong,” local artist Patrick Buie is back with another agreeable and casually charming single in “Precious Time.” Out today, the song feels a little less emotionally loaded than his last, which spoke of talks with God, but that’s actually a ruse of tone.",
          
          
            "image": {
              "url": "https:\/\/media1.fdncms.com\/saltlake\/imager\/u\/original\/17695181\/patrick_buie_s_precious_time_single_art.png",
              "width": 1288,
              "height": 1284,
              "@type": "ImageObject"
            },
          
          "datePublished": "2021-12-17T11:19:00",
          "dateModified": "2021-12-17T11:20:05",
          
            "author": {
              "name": "Erin Moore",
              "@type": "Person"
            },
          
          "publisher": {
            "name": "Salt Lake City Weekly",
            
              
              
              
              "logo": {
                "url": "https:\/\/www.cityweekly.net\/imager\/b\/google-amp-logo\/808579\/3f42\/slc_fbook.png",
                "width": 380,
                "height": 380,
                "@type": "ImageObject"
              },
            
            "@type": "Organization"
          },
          "@context": "https://schema.org",
          "@type": "NewsArticle"
        }
      </script>
  


</head>





  <body id="Post" class="blog BlogPost BuzzBlog Iapetus10Zone">



<div id="fb-root"></div>


  <script>
    (function () {
        var app = new Foundation.Facebook.Application();
        app.receiveAuthNotifications();
        app.receiveLikeNotifications();
    })();
  </script>




  <script>
    (function () {
      var googAuth = Foundation.Google.loadGoogleOauth().then(function(){
        //if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth initialized.")
      }.bind(this), function(){
        if(window.console) console.log("Foundation.Google.loadGoogleOauth OAuth didn't init.")
      })
    })()
  </script>
    

<!-- Leader -->
<div id="gridLeader">
  
</div><!-- end gridLeader -->

<div id="gridClamp">
  <!-- Header -->
  <div id="gridHeader">
    




  
  

  
  
  

  

    
      <div id="MobileDetect" class="GlobalHeader BlogPost " style="display:none">
        
        
          Switch to the <a href="https://m.cityweekly.net/BuzzBlog/archives/2021/12/17/music-update-dec-17" rel="nofollow alternate" media="handheld">mobile version</a> of this page.
        
      </div>
    

    <script>
      
      function setRedirectHash() {
        if (location.hash) {
          jQuery("#MobileDetect a[media='handheld']").each(function() {
            var link = jQuery(this);
            link.attr('href', link.attr('href').split('#')[0] + location.hash);
          });
        }
      }
      setRedirectHash();

      new Foundation.MobileDetectComponent("MobileDetect", true);
    </script>
  

<style>
#TopofsiteNoticePressbackers {
 max-width: 100%;
box-sizing: border-box; 
}
</style>
<a href="https://pressbackers.com/?page_id=28394" target="_blank" style="display: block;float:right; width:70px;background:#c02d31;border:1px solid #000; color:#fff; font-size:16px; font-weight:700; padding:8px 12px; margin:10px 10px 0px 0px;">
  DONATE
</a>
<div class="GlobalHeader BlogPost " id="TopofsiteNoticePressbackers" 
     style="font-size: 20px; font-weight: 500; text-align: left; width: 980px; padding: 10px; margin: 20px auto 10px; background-color: #fafcc5;">


<span style="font-size: 25px; font-weight: bold;"><strong>Support the Free Press</strong>.</span><br>
<span style="font-size: 12px; font-weight: bold;"><em>Facts matter. Truth matters. Journalism matters</em>.</span><br>
<span style="font-size: 18px; font-weight: bold;"><i>Salt Lake City Weekly</i> has been Utah's source of independent news and in-depth journalism since 1984. <br>Donate today to ensure the legacy continues.</strong></span><br>
 
</div>









<div class="clearfix" style="margin-bottom:10px;">
  <div style="float:left;width:728px;height:90px;background:#ccc;text-align:center;line-height:1;margin-right:10px;">
    <!-- /1605976/ROS_728x90_1 -->
          <div id="div-gpt-ad-ros_728x90_1" style="" data-content-type="ad" data-slot="/1605976/ROS_728x90_1" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_728x90_1');
                });
              </script>
          </div>
  </div>
  <div id="dailyFeedIssueBox" style="float:left;">
    
      
        <a href="https://issuu.com/cityweeklynewspaper" target="_blank">
          <img src="/imager/b/coverthisweek/17682524/47a9/CW_1_211216.jpg" 
               alt="Issue Cover"
               width="83" 
               height="90"/>
        </a>

      
      
      <a class="issueBoxLink" href="https://issuu.com/cityweeklynewspaper" target="_blank">
        <img src="/images/header-thisWeek.png" alt="This Week's Issue" />
      </a>
    
  </div>
</div>


  
    


    
    <div id="SearchLogin" class="GlobalHeader BlogPost thedailyfeed clearfix">

      

      
        <div id="logothedailyfeed"><a href="https://www.cityweekly.net/utah/BuzzBlogHome/Page">Buzz Blog</a></div>
      

      <ul id="followUs">
        <li>Follow Us</li>
        <li><a href="https://www.facebook.com/slcweekly" title="Facebook" id="facebook" target="_blank">Facebook</a></li>
        <li><a href="https://twitter.com/cityweekly" title="Twitter" id="twitter" target="_blank">Twitter</a></li>
        <li><a href="https://www.youtube.com/user/SLCityWeekly" title="YouTube" id="youtube" target="_blank">YouTube</a></li>
        <li><a href="https://www.instagram.com/slcweekly/" title="Instagram" id="instagram" target="_blank">Instagram</a></li>
        <!-- <li><a href="http://www.snapchat.com/" title="SnapChat" id="snapchat" target="_blank">SnapChat</a></li> -->
        <li><a href="/utah/SignUp/Page" title="Email" id="email">Email</a></li>
      </ul>

      

      
        

        

        
        <div class="search-wrap">
          <div class="search-link dropdown-link">
            <form class="search-form prepTextForm" id="searchbox_017793458706336421686:nk7zepvg1sm" action="https://posting.cityweekly.net/utah/Search">
              <input type="hidden" name="cx" value="017793458706336421686:nk7zepvg1sm" />
              <input type="hidden" name="cof" value="FORID:9" />
              <input type="submit" name="sa" value="Search" />
              <div class="searchElements">
                <input id="search-input" class="searchUpDown" autocomplete="off" type="text"  name="q" size="25" placeholder="" />
              </div>
              <ul id="search-dropdown" class="search-dropdown" style="display:none;">
                <li class="search-option"><a class="search-all" href="https://posting.cityweekly.net/utah/Search">All</a></li>
                <li class="search-option"><a href="https://www.cityweekly.net/utah/ArticleArchives">in Articles &amp; Posts</a></li>
                <li class="search-option"><a href="https://www.cityweekly.net/utah/EventSearch">in Events</a></li>
                <li class="search-option"><a href="https://www.cityweekly.net/utah/LocationSearch">in Locations</a></li>
                <li class="search-option"><a href="https://www.cityweekly.net/utah/ArticleArchives" data-category="2125047">in Videos</a></li>
              </ul>
            </form>
          </div>
        </div>

        <script>
        // 
        (function(){
          var searchFormSelector = '#SearchLogin form.search-form';
          var searchInputSelector = '#SearchLogin input#search-input';
          var searchDropdownSelector = '#SearchLogin ul#search-dropdown';
          var searchOptionLinkSelector = '#SearchLogin li.search-option a';

          focusInput = function(e){
            console.log(searchInputSelector);
            jQuery(searchInputSelector).off('focus', focusInput);
            jQuery(document).on('click', blurInput);
            jQuery(searchInputSelector).removeClass("searchUpDown");
            jQuery(searchDropdownSelector).slideDown('fast');
          }

          blurInput = function(e){
            // 
            if( jQuery(e.target).closest(searchFormSelector+', '+searchOptionLinkSelector).length === 0 ) {
              jQuery(document).off('click', blurInput);
              jQuery(searchInputSelector).on('focus', focusInput);
              jQuery(searchInputSelector).addClass("searchUpDown");
              jQuery(searchDropdownSelector).slideUp('fast');
            }
          }

          canProceed = function(){
            return jQuery(searchInputSelector).val() != "";
          }

          enterKeywordMessage = function (){
            jQuery(searchInputSelector).attr('placeholder',"Enter a keyword.");
            window.setTimeout(function(){
              jQuery(searchInputSelector).attr('placeholder',"");
            },1000);
          }

          jQuery(searchInputSelector).on('focus',focusInput);

          // 
          jQuery(searchFormSelector).submit(function(e){
            if(canProceed()){
              console.log('form submitted proceed');
            }else{
              e.preventDefault();
              console.log('form submitted can\'t proceed');
              enterKeywordMessage();
            }
          });

          // 
          jQuery(searchOptionLinkSelector).on('click', function(e){
            e.preventDefault();
            if(canProceed()){
              console.log('link clicked proceed');
              if(jQuery(e.target).hasClass('search-all')){
                jQuery(searchFormSelector).submit();
              } else {
                var newLocation = jQuery(e.target).attr('href') || "";
                var catVal = jQuery(e.target).attr('data-category');
                var catParam = catVal != undefined ? "&category="+catVal : "";
                window.location = newLocation 
                                + "?keywords=" + jQuery(searchInputSelector).val() 
                                + "&submit=Search" 
                                + catParam;
              }
            }else{
              console.log('link clicked can"t proceed');
              enterKeywordMessage();
            }
          });

        })();
        </script> 

      

      
      

      
        
        <ul data-view="loggedin" style="display:none">
          <li><strong data-label="username">Username</strong> / </li>
          <li><a href="https://posting.cityweekly.net/utah/MyProfile">View Profile</a> / </li>
          <li><a href="https://posting.cityweekly.net/utah/Profile/MySettings">Edit Profile</a> / </li>
          <li><a href="https://www.cityweekly.net/utah/Logout">Log Out</a></li>
        </ul>

        <ul data-view="loggedout" style="display:none">
          <li><a href="#LogIn">Log in</a> / </li>
          <li><a href="#CreateAccount">Create Account</a></li>
        </ul>
      

    </div><!-- #SearchLogin -->

    
    
      <script>
        new Foundation.LoginRequiredComponent("SearchLogin");
      </script>
    



  
  

  

  <div id="NavigationHorizontal" class="GlobalHeader BlogPost   thedailyfeed">

  

    

    
    <ul id="mainNav">
      
        <li class="first" id="NavItem_CityWeeklyHomeDailyFeed">
          <a href="https://www.cityweekly.net/utah/Home" target="_self" >Back to Home</a>
        </li>
      

        

        

        

        <li class="last" id="NavItem_TheDailyFeedEvents">
          <a href="https://www.cityweekly.net/utah/EventSearch" target="_self" >Events</a>
        </li>
        
      <li class="first" id="NavItem_Store">
          <a href="https://cwstore.cityweekly.net" target="_blank" class="subnav_link" id="SNAVL_Store">Marketplace</a>
        </li>
    </ul>

    
      
      
        
          <h3 class="hidden">Browse News</h3>
          <ul class="subnav_content" id="SNAV_News" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/cover-story/Category?oid=2125004" target="_self" title="">Cover Stories</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/news/Section?oid=2124970" target="_self" title="">News Features</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/BuzzBlogHome/Page" target="_self" title="">Blogs</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/hits-and-misses/Category?oid=2125005" target="_self" title="">Hits &amp; Misses</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/citizen-revolt/Category?oid=2125020" target="_self" title="">Citizen Revolt</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/opinion/Category?oid=2125013" target="_self" title="">Opinion</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/letters/Category?oid=2125012" target="_self" title="">Soap Box</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/private-eye/Category?oid=2125008" target="_self" title="">Private Eye</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/news-of-the-weird/Category?oid=2927528" target="_self" title="">News of the Weird</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Music</h3>
          <ul class="subnav_content" id="SNAV_Music" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/music/Category?oid=2124997" target="_self" title="">Music Features</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/music-picks/Category?oid=2284307" target="_self" title="">Music Picks</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse A&amp;E</h3>
          <ul class="subnav_content" id="SNAV_Culture" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/arts-and-entertainment/Category?oid=2125059" target="_self" title="">A&amp;E Features</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/entertainment-picks/Category?oid=2284340" target="_self" title="">Entertainment Picks</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/film-reviews/Category?oid=2124987" target="_self" title="">Film Reviews</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/movietimes" target="_blank" title="">Movie Times</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/the-straight-dope/Category?oid=2124996" target="_self" title="">The Straight Dope</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/free-will-astrology/Category?oid=2124993" target="_self" title="">Free Will Astrology</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Best of Utah</h3>
          <ul class="subnav_content" id="SNAV_BestofUtah" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/best-of-utah-2020/BestOf?oid=16057467" target="_self" title="">Best of Utah 2020</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/BestOf?category=2125000&year=2019" target="_blank" title="Best of Utah 2019
Our 30th annual ode to the people, places and businesses that make life in the Beehive State great.">Best of Utah 2019</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/best-of-utah-2018/BestOf?oid=11652100" target="_blank" title="">Best of Utah 2018</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Marketplace</h3>
          <ul class="subnav_content" id="SNAV_Store" style="display:none;">
        

        

        <li class="">
          <a href="https://cwstore.cityweekly.net/" target="_self" title="">CW Store</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://cwstore.cityweekly.net/Tickets" target="_self" title="">CW Tix</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Eat &amp; Drink</h3>
          <ul class="subnav_content" id="SNAV_restaurantsbars" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/restaurant-reviews/Category?oid=2125003" target="_self" title="">Restaurant Reviews</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/LocationSearch?locationSection=2125344" target="_self" title="">Restaurant Listings</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/food-news/Category?oid=2362594" target="_self" title="">Food News</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/drink/Category?oid=2362670" target="_self" title="">Beer Nerd</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/dining-guide-2019/Content?oid=13609103" target="_self" title="">Dining Guide 2019</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse News</h3>
          <ul class="subnav_content" id="SNAV_News" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/ArticleArchives?category=2125020" target="_self" title="">Citizen Revolt (mobile)</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Things To Read</h3>
          <ul class="subnav_content" id="SNAV_ThingsToRead" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/news/Section?oid=2124970" target="_self" title="">News</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/eat-and-drink/Section?oid=2124971" target="_self" title="">Food &amp; Drink</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/music/Section?oid=2124972" target="_self" title="">Music</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/culture/Section?oid=2124973" target="_self" title="">Culture</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Events</h3>
          <ul class="subnav_content" id="SNAV_ThingsToDo" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/FreeStuff" target="_self" title="">CW Events</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/EventSearch/" target="_self" title="">Events</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Things To Read</h3>
          <ul class="subnav_content" id="SNAV_ThingsToRead" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/news/Section?oid=2124970" target="_self" title="">News</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/eat-and-drink/Section?oid=2124971" target="_self" title="">Food &amp; Drink</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/music/Section?oid=2124972" target="_self" title="">Music</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/culture/Section?oid=2124973" target="_self" title="">Culture</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Things To Do</h3>
          <ul class="subnav_content" id="SNAV_ThingsToDo" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/utah/FreeStuff" target="_self" title="">Promotions</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/EventSearch/" target="_self" title="">Events</a>
        </li>
        
          </ul>
        
      
        
          <h3 class="hidden">Browse Film</h3>
          <ul class="subnav_content" id="SNAV_Film" style="display:none;">
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/film-reviews/Category?oid=2124987" target="_blank" title="">Film Reviews</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/utah/movietimes" target="_blank" title="">Movie Times</a>
        </li>
        
      
        

        

        <li class="">
          <a href="https://www.cityweekly.net/BuzzBlog/archives/sundance-film-festival/" target="_blank" title="">Sundance 2020</a>
        </li>
        
          </ul>
        
      
    

    

    
      
      
        <script>
        (function(){
          jQuery('#NavigationHorizontal .subnav_link').each(function(){
            var navigationID = jQuery(this).attr('id');
            var navigationSelector = '#'+navigationID;
            var navMenuSelector = '#SNAV_'+navigationID.split('_')[1];
            var navigationTimeout;
            var focusNavigation = function(e){
              window.clearTimeout(navigationTimeout);
              jQuery(navMenuSelector).css('left',Math.round(jQuery(navigationSelector).position().left)+'px');
              jQuery(navMenuSelector).show();
            }
            var blurNavigation = function(e){
                jQuery(navMenuSelector).hide();
              navigationTimeout = window.setTimeout(function(){
              },75);
            }
            jQuery(navMenuSelector+', '+navigationSelector).hover(focusNavigation,blurNavigation);
          });
        })();
        </script>
      
    
  

  </div><!-- end navigation -->


  </div><!-- end gridHeader -->

  <div id="gridMain">

    <div id="gridFrame">

      <div id="gridSpanningFeature">
        



  
  
  

  <!-- UIkit CSS -->
  <link rel="stylesheet" type="text/css" href="/fdn-system/assets/pub/styles/desktop.css?cb=543f42826e37176a60a24b07e0c9983c" />

  <!-- UIkit JS -->
  <script src="/fdn-system/assets/pub/scripts/uikit.min.js?cb=543f42826e37176a60a24b07e0c9983c"></script>
  <script src="/fdn-system/assets/pub/scripts/uikit-icons-fdn.min.js?cb=543f42826e37176a60a24b07e0c9983c"></script>


  

  <style>
    @media (min-width: 640px){
      div[id] .uk-child-width-1-3\@exs > * {
         width: calc(100% * 1 / 3.001);
      } 
    }
    #gridMainColumn .uk-width-1-2\@es {
      width: 50%;
    }

    #gridMainColumn .uk-child-width-auto\@exs > * {
      width: auto;
    }
    
    .uk-root {
      font-size: 14px;
    }
  </style>









  
  

  

  

  <div id="BlogHeader" class="SpanningFeature BlogPost  topic_aande BuzzBlog">
    <a href="https://www.cityweekly.net/blogs/BuzzBlog/">
    <h1 class="BuzzBlog">
      
        Buzz Blog
      
    </h1>
    </a>

    

    <p>
      
        <a href="https://www.cityweekly.net/utah/BuzzBlog/blogs/Archives">Archives</a> |
        <a href="/utah/Rss.xml?category=2125738">RSS</a>
      
      
    </p>
  </div>











  
  <link type="text/css" href="/foundation/scripts/jplayer/skin/jplayer.blue.monday.css" rel="stylesheet" />
  <script type="text/javascript" src="/foundation/scripts/jplayer/jquery.jplayer.min.js"></script>               
  
    <style>
    div.jp-audio,
    div.jp-video {
      /* Edit the font-size to counteract inherited font sizing.
       * Eg. 1.25em = 1 / 0.8em
       */
      font-size:1.25em;
    }      
    div.postBody div.inlineAudio,
    div#AudioPlayer div.inlineAudio {
      width: 400px;
      margin: auto;
      clear:both;
      }      
    </style>
  


  <div id="BlogsBlogPost" class="SpanningFeature BlogPost  topicView topic_aande home_follows">

    

    









































    

    
    

    
      
      
        <h2 class="blogDate">Friday, December 17, 2021</h2>
      

      
      <div class="blogPost buzzblog topic-aande topic-music topic-culture">
    
    
      <div class="postCategories">
                
        <span class="postCategory CategoryBuzzBlog">
          <a href="https://www.cityweekly.net/BuzzBlog/archives/aande/" class="topic-aande">A&E</a> / <a href="https://www.cityweekly.net/BuzzBlog/archives/music/" class="topic-music">Music</a> / <a href="https://www.cityweekly.net/BuzzBlog/archives/culture/" class="topic-culture">Culture</a>
        </span>
      </div>
    
    
    <h3 class="postTitle" id="a17695177">
      
      
      
      
      
      
        Music Update Dec. 17
      

      
    </h3>

    
      <h3 class="subheadline">New music from Patrick Buie, December 12 Minutes Max</h3>
    

    
      <h4 class="postedBy">
        

        
          <span class="byAttribute">Posted</span>
        
        
        
          
          <span class="byAttribute">By</span> <a href="https://www.cityweekly.net/author/erin-moore" rel="author">Erin Moore</a>
        
        
          
            on <span class="postTime"> December 17, 2021</span>, <span class="postTime">11:19 AM</span>
          
        
           
      </h4>
    

   
    
    

    
      
        
        















  
  
  

  

  

  
  


        <ul class="horizontalShareTools">
          <li class="l0 first">
            


  
  















  
  
  

  

  

  
  



  

  
    
    
  

  
  <style>
    div.l0.last div:first-child {float:right;}
  </style>
  
  <div id="ToolBarHorizontal" class="MicroComponent BlogPost ">
    <div style="width:100%; height: 20px;">
      <div class="l0 first" style="width:14%; height: 20px; float:left;">
        <fb:like href="https://www.cityweekly.net/BuzzBlog/archives/2021/12/17/music-update-dec-17" send="false" show_faces="false" action="like" font="tahoma" colorscheme="light" layout="button_count"></fb:like></div> <div class="l0" style="width:14%; height: 20px; float:left;"><a href="https://twitter.com/share?url=https%3A//www.cityweekly.net/BuzzBlog/archives/2021/12/17/music-update-dec-17&text=Music%20Update%20Dec.%2017" class="twitter-share-button" data-count="none">Tweet</a>
<script>
  dnLoadScript("https://platform.twitter.com/widgets.js", true);
</script></div> <div class="l0" style="width:14%; height: 20px; float:left;">


  

  

  

  <a href="https://pinterest.com/pin/create/button/?description=Music%20Update%20Dec.%2017&amp;media=https%3A%2F%2Fmedia1.fdncms.com%2Fsaltlake%2Fimager%2Fu%2Fslideshow%2F17695181%2Fpatrick_buie_s_precious_time_single_art.png&amp;url=https%3A%2F%2Fwww.cityweekly.net%2FBuzzBlog%2Farchives%2F2021%2F12%2F17%2Fmusic-update-dec-17" class="pin-it-button" count-layout="none">Pin It</a>
  <script>
  Foundation.documentReady.then(function () {
    new Foundation.Script("https://assets.pinterest.com/js/pinit.js", true);
  })
  </script>

</div> <div class="l0" style="width:14%; height: 20px; float:left;">

<a class="emailAction" title="Email" href="https://posting.cityweekly.net/utah/Tools/EmailFriend?oid=17695177" rel="nofollow" target="_blank" onclick="popupWindow('popupEmailFriend', this.href, 400, 650, 400, 10); return false">Email</a>

</div> <div class="l0" style="width:14%; height: 20px; float:left;">

<a class="printAction" title="Print" href="https://www.cityweekly.net/BuzzBlog/archives/2021/12/17/music-update-dec-17?mode=print" rel="nofollow" target="_blank">Print</a>
</div> <div class="l0" style="width:14%; height: 20px; float:left;">


  <a class="toggleActivator saveAction requiresLogin" title="My Favorites" href="https://posting.cityweekly.net/utah/Profile/MyFavorites?add=17695177">
    Favorite
  </a>
  <div class="togglePanel" data-toolsoid="17695177" data-toolsajaxmacro="addObject" style="display:none">
    <div class="loading">Saving&hellip;</div>
    <div class="ajaxUpdater" style="display:none"></div>
  </div>


</div> <div class="l0 last" style="width:14%; height: 20px; float:right;">




  <div class="addthis_toolbox addthis_default_style"><a href="https://www.addthis.com/bookmark.php?v=300&pubid=xa-50b3cdf517b9321d" addthis:url="https://www.cityweekly.net/BuzzBlog/archives/2021/12/17/music-update-dec-17" addthis:title="Music Update Dec. 17" addthis:description="New music from Patrick Buie, December 12 Minutes Max" class="addthis_button_compact">Share</a></div>
  <script type="text/javascript">
    dnLoadScript("https://s7.addthis.com/js/300/addthis_widget.js#pubid=xa-50b3cdf517b9321d", true);
  </script>


      </div>
    </div>
  </div>

  
  
    <script type="text/javascript">
      Foundation.Tools.setup();
    </script>
  


          </li>
        </ul>
      
    

    
    

    
    

    <div class="postBody">
      
          
      


      
     
       
      

        

        

        

        

        

        

        
        

        

        

        
      
      
      
      
       
      
      

      
      

      
      
        
        <div class="contentImageCenter" style="overflow:hidden;">                                              <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/saltlake/imager/u/original/17695181/patrick_buie_s_precious_time_single_art.png" class="zoomable" rel="contentImg_gal-17695177" title="">                  <img src="https://media1.fdncms.com/saltlake/imager/u/blog/17695181/patrick_buie_s_precious_time_single_art.png?cb=1639765165" width="665" height="663" alt="patrick_buie_s_precious_time_single_art.png" srcset="" />                </a>                                                                                                           <ul style="width:665px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>

<b>Patrick Buie releases “Precious Time”</b><br>
A few months after his woozy and dreamy single “(Tell Me) What Went Wrong,” local artist Patrick Buie is back with another agreeable and casually charming single in “Precious Time.” Out today, the song feels a little less emotionally loaded than his last, which spoke of talks with God, but that’s actually a ruse of tone. While sunny in many ways, the first line is “a smile is getting hard to find” and the refrain is “I’m losing my patience / you’re wasting my precious time.” The song itself almost feels like the kind of pretending that Buie is describing lyrically—all winking, sweet guitar parts and upbeat drums and tambourine shakes. Obviously, it seems that Buie’s precious time is being wasted, and he wonders that he’s wasting someone else’s too, but the way the song shakes out, it’s a putting off of that truth. It’s that thing in a relationship or a friendship where you’re telling yourself “it’s fine!” Is it fine? Perhaps not, but one thing is certain—this is a fine song indeed. Steam it where you stream, and keep up with Patrick Buie on Instagram at @patrickbuiemusic. 

            
          
            <br>
<br>

<div class="contentImageRight" style="overflow:hidden;">                                              <span class="clicktozoom">click to enlarge</span>                <a href="https://media1.fdncms.com/saltlake/imager/u/original/17695180/lula_asplund_perfoming_with_junior_mint_prince_-_pc_junior_mint_prince.jpeg" class="zoomable" rel="contentImg_gal-17695177" title="">                  <img src="https://media1.fdncms.com/saltlake/imager/u/blog/17695180/lula_asplund_perfoming_with_junior_mint_prince_-_pc_junior_mint_prince.jpeg?cb=1639765165" width="250" height="188" alt="lula_asplund_perfoming_with_junior_mint_prince_-_pc_junior_mint_prince.jpeg" srcset="" />                </a>                                                                                                           <ul style="width:250px;overflow:hidden;margin-left:auto;margin-right:auto;">                                                                                                                                                                                                                                          </ul>                                                       </div>

December 12 Minutes Max <br>
Another SLCPL gem coming at you, with the usual suspects: sound, dance, film. The locals-focused, monthly mini-arts series put on by our lovely library comes to you as usual this Sunday, Dec. 19 at 2 p.m. at slcpl.org. For the sound portion of the series, we’ve got Lula Asplund, a Utah native now based in Chicago who also performs with the experimental sound band Junior Mint Prince. Their work focuses on sound indeed, and aims to make apparent the physicality of sound, especially disembodied ones. For this performance, Asplund will be presenting an untitled piece on human touch as it relates to carving and sculpting. For the dance part of the series, Miche’ Smith will present a dance film titled <i>Count It All</i>, whose theme is “the joy we have to find within our pain, the joy we choose instead of our pain, and the pain that we joyfully rise above.” And for (more) film, there’s <i>A Silent Movement</i> and <i>I Thought I was Alone</i>, two visual poems that take the form of short video compilations, all filmed around Iowa City, and featuring spoken word from their creator, Amy Childress, and cello improvisations by Bay Area cellist Stevie Rose. Childress is especially at home at 12 Minutes Max, because she is also a librarian in SLC. As always, visit slcpl.org/events to view the series streaming.

            
          

          
          
            
            
              <div class="overflowComponent  EndContentInterstitial">
                
              </div>
      
      
      <div class="clearfix"></div>
      
      
      
    </div>

    
    
    

    

    

    

  </div> <!-- end blogPost -->
    
    <div class="clear"></div>
  </div>



















































  

  

  
  

  
  

  
     

     

  
  

  
  


  

  
  
  


  

  



  

  

  
  






  

  

  
  

  
    
  

  








  
  

  <div id="BlogsPreviousNext" class="SpanningFeature BlogPost ">
    <div class="prevNext">
      
        <a href="https://www.cityweekly.net/BuzzBlog/archives/2021/12/16/movie-reviews-new-releases-for-dec-17" class="prev" rel="prev">&laquo;&nbsp;Movie Reviews: New Releases for Dec&hellip;</a>
        
    </div>
  </div>




















    
    
    
    



























  
  

  
  


<div class="SpanningFeature BlogPost " ID="TellMeMore">
  <a href="https://www.cityweekly.net/utah/memberships/Page" target="_blank"><img src="/binary/c1bb/Olympian-Tell-Me-More.png" width="667" height="183" alt="" /></a>
</div>


  

  
    <div class="uk-root">
  

  





<div class="componentGrid-TwoZones-Auto-Expand uk-root uk-width-1-1 uk-flex uk-flex-row uk-flex-wrap fdn-component-grid-row@m" uk-height-match data-component-grid-id="TopStoriesVideoPair">

  <div class="uk-width-1-1 uk-width-auto@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
    

















<div class="ComponentZoneA Real1PlayerTrendingPairresponsive  trending-by-day uk-root fdn-margin-vert TrendingContentList comp-landing-trending" data-component-id="TrendingContentList">
  <div class="fdn-component-header-block uk-margin ">

      

      <h3 class="fdn-component-header-text uk-margin-remove ">
        
          Trending
        
      </h3>

      

      
    </div>

    
    
    

    
        <ul class="pres-ContentListHeadline uk-list uk-list-divider">
      
      

      <li class="fdn-pres-item">
    <a class="uk-flex uk-flex-top" href="https://www.cityweekly.net/BuzzBlog/archives/2021/12/16/movie-reviews-new-releases-for-dec-17">
      <p class="fdn-teaser-headline">
        Movie Reviews: New Releases for Dec. 17
      </p>
    </a>
  </li>

      
   
    
      

      <li class="fdn-pres-item">
    <a class="uk-flex uk-flex-top" href="https://www.cityweekly.net/BuzzBlog/archives/2021/12/14/movie-review-spider-man-no-way-home">
      <p class="fdn-teaser-headline">
        Movie Review: SPIDER-MAN: NO WAY HOME
      </p>
    </a>
  </li>

      
   
    
      

      <li class="fdn-pres-item">
    <a class="uk-flex uk-flex-top" href="https://www.cityweekly.net/BuzzBlog/archives/2021/12/09/movie-reviews-new-releases-for-dec-10">
      <p class="fdn-teaser-headline">
        Movie Reviews: New Releases for Dec. 10
      </p>
    </a>
  </li>

      
   
    
        </ul>
      

  

</div>

    
  </div>

  <div class="uk-width-1-1 uk-width-expand@m uk-flex uk-flex-column uk-inline fdn-component-grid-zone">
    











  
  

  
  
    <script src="https://www.voqally.com/hub/app/r.js?key=52a7d35387bd03f701a3c810b1bbf554" async></script>

  
  


    
  </div>

</div>


  
    </div>
  



<script type="text/javascript">
  function setBioLink(){
    jQuery(".bio .readMore").click(function(e){
      e.preventDefault();
      var elem = jQuery(this);
      if (elem.prevAll(".authorBioLong").is(":hidden")){
        elem.prevAll(".authorBioShort").fadeOut("fast", function(){
          elem.prevAll(".authorBioLong").fadeIn("fast");
          elem.html("less");
        });          
      } else {
        elem.prevAll(".authorBioLong").fadeOut("fast", function(){
          elem.prevAll(".authorBioShort").fadeIn("fast");                   
          elem.html("more");
        });          
      }
    })
  }
</script>





  <div id="AbouttheauthorWrapper" class="SpanningFeature BlogPost Wrapper">
  
    <div id="Abouttheauthor" class="SpanningFeature BlogPost  clearfix">
      
        <h3><span class="headingText">About The Author</span></h3>
        
      <a href="https://www.cityweekly.net/author/erin-moore">
      
        
        <img src="/imager/b/story/13651595/def1/unnamed-4.jpg" border="0" width="200" height="150" alt="Erin Moore" />
      
      </a>
      <a href="https://www.cityweekly.net/author/erin-moore"><h4>Erin Moore</h4></a> 

      
        
          <div class="email"><a href="mailto:music@cityweekly.net">music@cityweekly.net</a></div>
        
      
    
      

      
        <div class="twitter"><a href="https://twitter.com/errrands_" target="_blank">@errrands_</a></div>
      
    
      

      
        <div class="bio">
          <span class="label"><b>Bio:</b><br /></span>
          
            Erin Moore is <i>City Weekly</i>'s music editor. Email tips to: music@cityweekly.net.
                  
        </div>
      
    
    </div> <!-- Abouttheauthor -->
  
  </div>
  
  <script type="text/javascript">
  Foundation.documentReady.then(function () {
    var twitterLinkSelector = '#Abouttheauthor div.twitter a';
    jQuery(twitterLinkSelector).each(function(){
      jQuery(this).clone().insertAfter(this).addClass('twitter-follow-button').removeClass('twitter').attr('data-show-count','true').attr('data-lang','en').attr('data-show-screen-name','false');
    });
    (new Foundation.Script("https://platform.twitter.com/widgets.js", true)).then(function () {
      !function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="https://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");
      });
  });
  </script>

<script>setBioLink();</script>












  
  
      <div id="RecentbyTopic" class="SpanningFeature BlogPost ">
        <h3 class="latest">
          <span class="headingText">
          
            On Topic...
                
          </span>
        </h3>
        
        <ul class="moduleList">
    
    
    
    

    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/BuzzBlog/archives/2021/12/16/movie-reviews-new-releases-for-dec-17">Movie Reviews: New Releases for Dec. 17</a>
    </h4>
    
      <h5 class="subhead">
        Spider-Man: No Way Home, Nightmare Alley, Swan Song, The Novice
      </h5>
    
    <ul>
      
        <li class="l1 byline">By Scott Renshaw</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Dec 16, 2021</span>
        </li>
      
    </ul>
  </li>

    
  
    
    
    

    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/BuzzBlog/archives/2021/12/14/movie-review-spider-man-no-way-home">Movie Review: SPIDER-MAN: NO WAY HOME</a>
    </h4>
    
      <h5 class="subhead">
        For better, or for worse, it's entirely a celebration of 20 years' worth of cinematic Spidey
      </h5>
    
    <ul>
      
        <li class="l1 byline">By Scott Renshaw</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Dec 14, 2021</span>
        </li>
      
    </ul>
  </li>

    
  
    
    
    

    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/BuzzBlog/archives/2021/12/09/movie-reviews-new-releases-for-dec-10">Movie Reviews: New Releases for Dec. 10</a>
    </h4>
    
      <h5 class="subhead">
        Being the Ricardos, West Side Story, Don't Look Up and more
      </h5>
    
    <ul>
      
        <li class="l1 byline">By Scott Renshaw</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Dec  9, 2021</span>
        </li>
      
    </ul>
  </li>

    
  
      
        <li class="l0 storyItem">
          
          
            
             <a href="https://www.cityweekly.net/BuzzBlog/archives/a%26e/" class="more">More A&E &raquo;</a>
            
             <a href="https://www.cityweekly.net/BuzzBlog/archives/music/" class="more">More Music &raquo;</a>
            
             <a href="https://www.cityweekly.net/BuzzBlog/archives/culture/" class="more">More Culture &raquo;</a>
            
          
          
        </li>
      
        </ul>
      </div>
    
  









  

  

  
    <div id="MorebyThisAuthorWrapper" class="SpanningFeature BlogPost Wrapper">

    
      
      
          <div id="MorebyThisAuthor" class="SpanningFeature BlogPost ">
            <h3><span class="headingText">More by Erin Moore</span></h3>
            <ul class="moduleList">
        
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/utah/debuting-alicia/Content?oid=17682948">Debuting Alicia</a>
    </h4>
    
      <h5 class="subhead">
        Alicia Stockman narrows a career's worth of songs into her first album.
      </h5>
    
    <ul>
      
        <li class="l1 byline">By Erin Moore</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Dec 15, 2021</span>
        </li>
      
    </ul>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/utah/bringing-back-the-battle/Content?oid=17653575">Bringing Back the Battle</a>
    </h4>
    
      <h5 class="subhead">
        After two years, Velour once again hosts its community-building, potentially star-making showcase.
      </h5>
    
    <ul>
      
        <li class="l1 byline">By Erin Moore</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Dec  8, 2021</span>
        </li>
      
    </ul>
  </li>
        
        

      
        
        
        <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/BuzzBlog/archives/2021/12/03/music-update-dec-3">Music Update Dec. 3</a>
    </h4>
    
      <h5 class="subhead">
        Adam Michael Terry record sale at Modern West Fine Art, The Pranksters at O.P. Rockwell
      </h5>
    
    <ul>
      
        <li class="l1 byline">By Erin Moore</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Dec  3, 2021</span>
        </li>
      
    </ul>
  </li>
        
        

      
             <li class="l0 storyItem more">
               <a href="https://www.cityweekly.net/utah/ArticleArchives?author=13651595" class="more">More &raquo;</a>
             </li>
             </ul>
          </div>
        
    
   </div>  
   
  










  
  
      <div id="LatestInCategory" class="SpanningFeature BlogPost ">
        <h3 class="latestbuzz_blog"><span class="headingText">Latest in Buzz Blog</span></h3>
        <ul class="moduleList ui list grouped expanded">
    
    
    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/BuzzBlog/archives/2021/12/16/movie-reviews-new-releases-for-dec-17">Movie Reviews: New Releases for Dec. 17</a>
    </h4>
    
      <h5 class="subhead">
        Spider-Man: No Way Home, Nightmare Alley, Swan Song, The Novice
      </h5>
    
    <ul>
      
        <li class="l1 byline">By Scott Renshaw</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Dec 16, 2021</span>
        </li>
      
    </ul>
  </li>
    
  
    
    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/BuzzBlog/archives/2021/12/14/movie-review-spider-man-no-way-home">Movie Review: SPIDER-MAN: NO WAY HOME</a>
    </h4>
    
      <h5 class="subhead">
        For better, or for worse, it's entirely a celebration of 20 years' worth of cinematic Spidey
      </h5>
    
    <ul>
      
        <li class="l1 byline">By Scott Renshaw</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Dec 14, 2021</span>
        </li>
      
    </ul>
  </li>
    
  
    
    <li class="l0 storyItem">
    

    

    <h4 class="headline">
      <a href="https://www.cityweekly.net/BuzzBlog/archives/2021/12/09/movie-reviews-new-releases-for-dec-10">Movie Reviews: New Releases for Dec. 10</a>
    </h4>
    
      <h5 class="subhead">
        Being the Ricardos, West Side Story, Don't Look Up and more
      </h5>
    
    <ul>
      
        <li class="l1 byline">By Scott Renshaw</li>
      
      
        <li class="l1 longOnly">
          <span class="date">Dec  9, 2021</span>
        </li>
      
    </ul>
  </li>
    
  
        
            <li class="l0 storyItem more">
              <a href="https://www.cityweekly.net/utah/ArticleArchives?category=2125738" class="more">More &raquo;</a>
            </li>
          </ul>
        
      </div>
    


<div id="AdBottomTwo300x250" class="SpanningFeature BlogPost ads ">
  <!-- /1605976/ROS_300x250_6 -->
          <div id="div-gpt-ad-ros_300x250_6" style="" data-content-type="ad" data-slot="/1605976/ROS_300x250_6" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_300x250_6');
                });
              </script>
          </div>
  <!-- /1605976/ROS_300x250_7 -->
          <div id="div-gpt-ad-ros_300x250_7" style="" data-content-type="ad" data-slot="/1605976/ROS_300x250_7" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_300x250_7');
                });
              </script>
          </div>
</div><!-- #AdBottomTwo300x250 -->






      </div><!-- gridSpanningFeature -->
      
      <div id="gridSpanningFeature2">
        


  

  

  
  

  
    
  

  















    
    
    
    



























  
  

  
  






      </div><!-- gridSpanningFeature2 -->

      <div id="gridColumnContainer" class="clearfix">

        <div id="gridMainColumn1">
          
        </div><!-- gridMainColumn1 -->
        
        <div id="gridMainColumn2">
          
        </div><!-- gridMainColumn2 -->

      </div><!-- end gridColumnContainer -->

    </div><!-- end gridFrame -->

    <div id="gridRightColumn">   
      <div id="gridSpanningIsland">
        <div id="Promotionslink" class="SpanningIsland BlogPost ">
<a href="https://www.cityweekly.net/utah/FreeStuff" target="_blank">Promotions</a>
</div>
 <div id="MovieTimesLink" class="SpanningIsland BlogPost ">
   <a href="https://www.cityweekly.net/utah/MovieTimes"><img src="/general/graphics/MovieTimesTicket.png" border="0" title="Movie Times" alt="Movie Times"></a>
  </div>



<style>#WhatsHappeningWidget {width:300px;margin:1em auto;}</style>




   
    <div id="WhatsHappeningWidget" class="SpanningIsland BlogPost Widget">
         
       <script type="text/javascript" src="//portal.CitySpark.com/WidgetScripts/8028" > </script>
       
    </div>  
     
    


    
<div id="Ad300x250x1" class="SpanningIsland BlogPost ">
  <!-- /1605976/ROS_300x250_1 -->
          <div id="div-gpt-ad-ros_300x250_1" style="" data-content-type="ad" data-slot="/1605976/ROS_300x250_1" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_300x250_1');
                });
              </script>
          </div>
</div><!-- #Ad300x250x1 --><div id="Ad300x250x2" class="SpanningIsland BlogPost ">
  <!-- /1605976/ROS_300x250_2 -->
          <div id="div-gpt-ad-ros_300x250_2" style="" data-content-type="ad" data-slot="/1605976/ROS_300x250_2" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_300x250_2');
                });
              </script>
          </div>
</div><!-- #Ad300x250x2 --><div id="TheSocialWidget" class="SpanningIsland BlogPost ">
  
    <div class="header" style="display:block;text-align:center;"><img src="/binary/9c5c/thesocial.jpg" width="300" height="62" alt="" /></div>
    <iframe src="https://cityweekly.friends2follow.com/f2f/widget/html/socialstack/101/0/12/160/1-4/1/1" frameborder="0" height="600" width="300" scrolling="no"></iframe>
  
</div><div id="Ad300x250x3" class="SpanningIsland BlogPost ">
  <!-- /1605976/ROS_300x250_3 -->
          <div id="div-gpt-ad-ros_300x250_3" style="" data-content-type="ad" data-slot="/1605976/ROS_300x250_3" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_300x250_3');
                });
              </script>
          </div>
</div><!-- #Ad300x250x3 --><div id="Ad300x250x4" class="SpanningIsland BlogPost ">
  <!-- /1605976/ROS_300x250_4 -->
          <div id="div-gpt-ad-ros_300x250_4" style="" data-content-type="ad" data-slot="/1605976/ROS_300x250_4" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_300x250_4');
                });
              </script>
          </div>
</div><!-- #Ad300x250x4 --><div id="Ad300x250x5" class="SpanningIsland BlogPost ">
  <!-- /1605976/ROS_300x250_5 -->
          <div id="div-gpt-ad-ros_300x250_5" style="" data-content-type="ad" data-slot="/1605976/ROS_300x250_5" data-output="asynchronous" data-width="300" data-height="250">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-ros_300x250_5');
                });
              </script>
          </div>
</div><!-- #Ad300x250x5 -->

<div id="SocialStack" class="SpanningIsland BlogPost ">
      
    <div class="header" style="display:block;background-color:#e9e9e9;text-align:center;padding:10px;"><img src="/binary/bc2c/staffSocial.png" width="280" height="90" alt="" /></div>
    <iframe src="https://cityweekly.friends2follow.com/f2f/widget/html/socialstack/50/0/12/160/1-4/1" frameborder="0" height="600" width="300" scrolling="no"></iframe>
    <center><span style="font-size:40px;  color:#66798F">
      <a href="https://www.facebook.com/slcweekly" target="_blank" style="text-decoration:none;">&middot;&middot;&middot;</a>
     </span></center>
</div>
      </div><!-- end gridSpanningIsland -->  
     
      <div id="gridMainSidebar">
        
      </div><!-- end gridMainSidebar -->

      <div id="gridAdSidebar">
        
      </div><!-- end gridAdSidebar -->
      
      <div id="gridBottomSidebar">
        
      </div>
    </div><!-- end gridRightColumn -->
    
    <!-- Footer -->
    <div id="gridFooter">
      


    <div id="FooterNavigation" class="GlobalFooter BlogPost ">
      <ul>
  
  
  <li class="">
    <a href="https://www.cityweekly.net/utah/Home" target="_self">
      
        Home
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/AboutUs/Page" target="_self">
      
        Who We Are
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/ContactUs/Page" target="_self">
      
        Contact
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/Circulation/Page" target="_self">
      
        Circulation
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/WorkWithUs/Page" target="_self">
      
        Work With Us
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/Advertising/Page" target="_self">
      
        Advertising
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/SignUp/Page" target="_blank">
      
        Newsletters
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/special-guides/Section?oid=2124976" target="_self">
      
        Guides
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/IssueArchives?year=2019" target="_blank">
      
        E-Weekly
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/IssueArchives" target="_self">
      
        Issue Archives
      
    </a>
    
    
      <span>|</span>
    
  </li> 
  

  
  <li class="">
    <a href="https://www.cityweekly.net/utah/PrivacyPolicyTermsofUse/Page" target="_self">
      
        Privacy Policy / Terms of Use
      
    </a>
    
    
  </li> 
  

      </ul>
    </div>
  





<div id="footerCopyright">
  <p>
   &copy; 2021
    
      Salt Lake City Weekly 
     
   <br><br>
   Website powered by <a href="https://www.publishwithfoundation.com/" target="_blank">Foundation</a>
  </p>
</div>





<!-- GOOGLE ANALYTICS -->

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-24101179-1', 'auto');
  ga('send', 'pageview');

var trackOutboundLink = function(url) {
   ga('send', 'event', 'outbound', 'click', url, {
     'transport': 'beacon',
     'hitCallback': function(){document.location = url;}
   });
}

</script>

<!-- END GOOGLE ANALYTICS -->





<!-- QUANTCAST TRACKING CODE --> 

<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-a4LDpi_DEopn-"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-a4LDpi_DEopn-.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
 
<!-- END QUANTCAST  -->


  <img src="/foundation/images/icons/pixel.gif?oid=17695177" alt="" />


    </div><!-- end gridFooter -->

  </div><!-- end gridMain -->

</div><!-- end gridClamp -->

<!-- Closer -->
<div id="gridCloser">
  <div id="AdFixedLeaderboard728x90" class="Closer BlogPost ">
  <!-- /1605976/FixedLeaderboard -->
          <div id="div-gpt-ad-fixedleaderboard" style="" data-content-type="ad" data-slot="/1605976/FixedLeaderboard" data-output="asynchronous" data-width="728" data-height="90">
              <script type='text/javascript'>
                googletag.cmd.push(function() {
                  googletag.display('div-gpt-ad-fixedleaderboard');
                });
              </script>
          </div>

  
  
    
    <script>
    jQuery('div#div-gpt-ad-fixedleaderboard').append(jQuery('<div class="closeButt">❌</div>'))
    jQuery('div#div-gpt-ad-fixedleaderboard div.closeButt').click(function(){
      jQuery('div#div-gpt-ad-fixedleaderboard').hide()
    })
    </script>
</div>
</div><!-- end gridCloser -->
    </body>
</html>
  


